which codec?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

which codec?

Patrick Welche
gst-play-1.0 tells me

Missing decoder: ITU H.264 (video/x-h264, variant=(string)itu, framerate=(fraction)10/1, width=(int)1000, height=(int)670)

when trying to play a video from one of our cameras.

libav:  avdec_h264: libav H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 decoder

is therefore not the right one. Any idea what can decode it?


Cheers,

Patrick
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: which codec?

Olivier Crête-3
Hi,

It is the right one! But the caps from the demuxer seem slightly odd,
we normally don't put a "variant" for H.264, and the stream-type is
missing.

Olivier

On Wed, 2020-02-19 at 17:16 +0000, Patrick Welche wrote:

> gst-play-1.0 tells me
>
> Missing decoder: ITU H.264 (video/x-h264, variant=(string)itu, framerate=(fraction)10/1, width=(int)1000, height=(int)670)
>
> when trying to play a video from one of our cameras.
>
> libav:  avdec_h264: libav H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 decoder
>
> is therefore not the right one. Any idea what can decode it?
>
>
> Cheers,
>
> Patrick
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
--
Olivier Crête
[hidden email]

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: which codec?

Tim Müller
In reply to this post by Patrick Welche
On Wed, 2020-02-19 at 17:16 +0000, Patrick Welche wrote:

Hi Patrick,

> gst-play-1.0 tells me
>
> Missing decoder: ITU H.264 (video/x-h264, variant=(string)itu,
> framerate=(fraction)10/1, width=(int)1000, height=(int)670)
>
> when trying to play a video from one of our cameras.
>
> libav:  avdec_h264: libav H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
> decoder
>
> is therefore not the right one. Any idea what can decode it?

You might be missing h264parse from gst-plugins-bad.

Cheers
 Tim

--
Tim Müller, Centricular Ltd - http://www.centricular.com

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel