undefined symbol in custom plugin(gst_video_filter_get_type)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

undefined symbol in custom plugin(gst_video_filter_get_type)

dpw157
Hey all,

I have been trying to get my custom plugin working with gstreamer. I have
been able to get the example myfilter plugin working and registered within
gstreamer. But the one that i wrote that inherits from gstvideofilter does
not work. The error that occurs is  ": src/.libs/libvideoelement.so:
undefined symbol: gst_video_filter_get_type". From my understanding this
should have been auto generated by the G_DEFINE_TYPE() of gstvideofilter and
included within my own file when i did #include
<gst/video/gstvideofilter.h>.

Any help would be appreciated, i am just trying to understand and learn how
to make my own plugins. Thanks for taking the time to look at this post.





--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

killerrats
did you get the library to compile with?



-----
------------------------------
Gstreamer 1.12.4
------------------------------
Windows
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
------------------------------
Gstreamer 1.14.4
------------------------------
Windows
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

dpw157
yes i have the library. Could it be that the path to it is bad or something.
I tried setting a gst-plugin-path to the folder where it is located but that
didnt help



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

killerrats
In reply to this post by killerrats
Library include gstvideo-1.0.lib



-----
------------------------------
Gstreamer 1.12.4
------------------------------
Windows
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
------------------------------
Gstreamer 1.14.4
------------------------------
Windows
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

killerrats
In reply to this post by dpw157
I'm guessing your using linux. I don't know linux very well.



-----
------------------------------
Gstreamer 1.12.4
------------------------------
Windows
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
------------------------------
Gstreamer 1.14.4
------------------------------
Windows
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

dpw157
yes i am using linux sorry for the confusion i should have added that in the
beginning.



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

bdjukic
Hi there! Just wondering if you managed to resolve the above issue? I'm
seeing the exact same problem atm.

Thanks!

B.



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol in custom plugin(gst_video_filter_get_type)

Michael Gruner
Hi Bdjukic

To use GStreamer video utilities you need to link in additional libraries. The simplest way is to use pkg-config. Append the following flags to your build process:

VIDEO_CFLAGS=`pkg-config --cflags gstreamer-video-1.0`
VIDEO_CFLAGS=`pkg-config --libs gstreamer-video-1.0`

Michael
RidgeRun

> On Aug 10, 2018, at 06:08, bdjukic <[hidden email]> wrote:
>
> Hi there! Just wondering if you managed to resolve the above issue? I'm
> seeing the exact same problem atm.
>
> Thanks!
>
> B.
>
>
>
> --
> Sent from: http://gstreamer-devel.966125.n4.nabble.com/
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel