udpsrc doesn't work on 2 NIC & Port mirror linux setup

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

udpsrc doesn't work on 2 NIC & Port mirror linux setup

I've tried a lot of stuff, but I can't seem to get it to work. (Same problem
exists with ffmpeg/vlc)

Basically, I can't get the UDP Stream directly into a videotool. I can
verify the data coming in through tcpdump/wireshark etc. and i can also
create the videofiles through gstreamer/ffmpeg afterwards, but I can't use
the udp source as input.

The current setup is the following:
The camera streams MJPEG through UDP to a fixed address & port. I port
mirrored the data from the camera, so that I can verify the data coming in
through wireshark on a 3rd device.

The reason behind doing this is that multicast is not supported, so I need a
way to get the data on 2 devices through unicast. Port mirroring seemed like
a viable solution.

Am I missing something here? What do I need to do to get this working?
I thought maybe it's due to the two networkinterface setup as I use 1x usb
to ethernet for the port mirror and 1x ethernet for the web, but
disconnecting the other shows no difference.
The routing seems correct too: "ip route get camera.ip" returns that the
routing is through the usb to ethernet on my static ip.

Example of an attempt:

Gst-launch-1.0 udpsrc port=streamingport(confirmed through wireshark) !
jpegdec ! videorate ! video/x-raw,framerate=30/1 ! autovideosink (does not
i also tried the address and uri properties of udpsrc

Gst-launch-1.0 filesrc location=hexdumpfile.txt ! jpegdec ! videorate !
video/x-raw,framerate=30/1 ! autovideosink (does work)

Sent from: http://gstreamer-devel.966125.n4.nabble.com/
gstreamer-devel mailing list
[hidden email]