Quantcast

nlesource / nleurisource - inpoint and duration not working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

nlesource / nleurisource - inpoint and duration not working

Christophe Da Silva
Hi,

I use gst-editing-tools (try with version 1.6.2 and 1.10.4) and the inpoint and duration args for nlesource or nleurisource does not work.

gst-launch-1.0 nleurisource uri=file:///my_video.mp4 inpoint=10000000000 duration=5000000000 ! decodebin ! videoconvert ! autovideosink

My pipeline is working but all the video is used (from first to last frame). The inpoint and duration have no consequence.

These options are still working?

And in this case, is this a bug from this version and do I need to upgrade my libs?

Regards,

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: nlesource / nleurisource - inpoint and duration not working

Thibault Saunier-4
Hello Christophe,

Using NLE with gst-launch is generally not supported, there are a few
problems to solve.

I guess the issue here is that you are using a nlesource outside a
composition, which worked at some point so I guess it is a regression,
you should open a bug report.

Also not that urisource contains an uridecodebin so you should not use
any decodebin afterward.

Regads,

Thibault

On Tue, Apr 25, 2017 at 10:20 AM, Christophe Da Silva
<[hidden email]> wrote:

> Hi,
>
> I use gst-editing-tools (try with version 1.6.2 and 1.10.4) and the inpoint
> and duration args for nlesource or nleurisource does not work.
>
> gst-launch-1.0 nleurisource uri=file:///my_video.mp4 inpoint=10000000000
> duration=5000000000 ! decodebin ! videoconvert ! autovideosink
>
> My pipeline is working but all the video is used (from first to last frame).
> The inpoint and duration have no consequence.
>
> These options are still working?
>
> And in this case, is this a bug from this version and do I need to upgrade
> my libs?
>
> Regards,
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
>
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Loading...