how to play the AAC audio by Gstreamer?

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|

how to play the AAC audio by Gstreamer?

michael young
Hi all:
    I cannot use the Gstreamer play the AAC music, can you tell me HOW
TO play it ?? Thx

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael smith-6-3
On Wed, Jul 21, 2010 at 3:22 AM, michael young <[hidden email]> wrote:
> Hi all:
>    I cannot use the Gstreamer play the AAC music, can you tell me HOW
> TO play it ?? Thx

Are you having trouble getting a gstreamer based application to play
AAC, perhaps in m4a files?

Most likely this means you don't have an appropriate AAC decoder. The
solution: install an AAC decoder plugin.

Since you gave zero information about what application you're using,
what OS you're running it on, and so on, it's obviously impossible to
give exact details.

Mike

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi mike:
    thx for your reply, and I run gstreamer-0.10 on Ubuntu 9.10. I do
play the m4a file.
and HOW I get and install an AAC decoder plugin?? thx.
    When I play the m4a file , I got the information like this:

** Message: don't know how to handle audio/mpeg, mpegversion=(int)4,
framed=(boolean)true, stream-format=(string)raw,
codec_data=(buffer)1210, rate=(int)44100, channels=(int)2


On Thu, Jul 22, 2010 at 1:18 AM, Michael Smith <[hidden email]> wrote:

> On Wed, Jul 21, 2010 at 3:22 AM, michael young <[hidden email]> wrote:
>> Hi all:
>>    I cannot use the Gstreamer play the AAC music, can you tell me HOW
>> TO play it ?? Thx
>
> Are you having trouble getting a gstreamer based application to play
> AAC, perhaps in m4a files?
>
> Most likely this means you don't have an appropriate AAC decoder. The
> solution: install an AAC decoder plugin.
>
> Since you gave zero information about what application you're using,
> what OS you're running it on, and so on, it's obviously impossible to
> give exact details.
>
> Mike
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sandeep Prakash
Hi,

michael young wrote
and HOW I get and install an AAC decoder plugin?? thx.
You can install "faad" plugin present in gst-plugins-bad package or the "ffdec_aac" which is present
in gst-ffmpeg package.


Regards,
Sandeep Prakash
http://sandeepprakash.homeip.net
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi
     I try it like Sandeep said, first I install the libfaad-dev
through Ubuntu's apt-get.
then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
play m4a file,
the error message is just the old one.
      and then I installed the gst-plugin-bad, play the m4a file again
, I got information
like this:

(gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
/usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
gst_photography_get_focus_mode

Do you know what's wrong here?? thx

On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash <[hidden email]> wrote:

>
> Hi,
>
>
> michael young wrote:
>>
>> and HOW I get and install an AAC decoder plugin?? thx.
>>
>
> You can install "faad" plugin present in gst-plugins-bad package or the
> "ffdec_aac" which is present
> in gst-ffmpeg package.
>
>
> Regards,
> Sandeep Prakash
> http://sandeepprakash.homeip.net
> --
> View this message in context: http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-audio-by-Gstreamer-tp2296882p2298084.html
> Sent from the GStreamer-devel mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht
 
Can you attach the AAC file which you are not able to play ?
 
One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
 



 
On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
Hi
    I try it like Sandeep said, first I install the libfaad-dev
through Ubuntu's apt-get.
then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
play m4a file,
the error message is just the old one.
     and then I installed the gst-plugin-bad, play the m4a file again
, I got information
like this:

(gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
/usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
gst_photography_get_focus_mode

Do you know what's wrong here?? thx

On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash <[hidden email]> wrote:
>
> Hi,
>
>
> michael young wrote:
>>
>> and HOW I get and install an AAC decoder plugin?? thx.
>>
>
> You can install "faad" plugin present in gst-plugins-bad package or the
> "ffdec_aac" which is present
> in gst-ffmpeg package.
>
>
> Regards,
> Sandeep Prakash
> http://sandeepprakash.homeip.net
> --
> View this message in context: http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-audio-by-Gstreamer-tp2296882p2298084.html
> Sent from the GStreamer-devel mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
HI sudarshan:

check the attached file , and the file can play in Mplayer, so I think
the file is ok.
and i list the information below:
$ gst-inspect-0.10 | grep aac
faac:  faac: AAC audio encoder
audioparsersbad:  aacparse: AAC audio stream parser
ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
typefindfunctions: adts_mpeg_stream: aac


On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht
<[hidden email]> wrote:

>
> Can you attach the AAC file which you are not able to play ?
>
> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>
>
>
>
> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>
>> Hi
>>     I try it like Sandeep said, first I install the libfaad-dev
>> through Ubuntu's apt-get.
>> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
>> play m4a file,
>> the error message is just the old one.
>>      and then I installed the gst-plugin-bad, play the m4a file again
>> , I got information
>> like this:
>>
>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>> gst_photography_get_focus_mode
>>
>> Do you know what's wrong here?? thx
>>
>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash <[hidden email]>
>> wrote:
>> >
>> > Hi,
>> >
>> >
>> > michael young wrote:
>> >>
>> >> and HOW I get and install an AAC decoder plugin?? thx.
>> >>
>> >
>> > You can install "faad" plugin present in gst-plugins-bad package or the
>> > "ffdec_aac" which is present
>> > in gst-ffmpeg package.
>> >
>> >
>> > Regards,
>> > Sandeep Prakash
>> > http://sandeepprakash.homeip.net
>> > --
>> > View this message in context:
>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-audio-by-Gstreamer-tp2296882p2298084.html
>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>> >
>> >
>> > ------------------------------------------------------------------------------
>> > This SF.net email is sponsored by Sprint
>> > What will you do first with EVO, the first 4G phone?
>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> > _______________________________________________
>> > gstreamer-devel mailing list
>> > [hidden email]
>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>> >
>>
>>
>> ------------------------------------------------------------------------------
>> This SF.net email is sponsored by Sprint
>> What will you do first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>
>
> --
> Regards,
>
> Sudarshan Bisht
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel

1.m4a (11M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht

Print shows that  you don't have faad ( aac decoder plugin) . After installing libfaad2 , run configure in gst-plugins-bad then it gives some prints where it shows which are the pluings those are depending on library are built/not built. There what you see about faad ?

Or you can try one more thing ,

gst-launch filesrc location=filename.m4a ! ffdec_aac ! audioconvert ! alsasink

or

gst-launch filesrc location=filename.m4a ! qtdemux ! ffdec_aac ! audioconvert ! alsasink




On Thu, Jul 22, 2010 at 9:00 AM, michael young <[hidden email]> wrote:
HI sudarshan:

check the attached file , and the file can play in Mplayer, so I think
the file is ok.
and i list the information below:
$ gst-inspect-0.10 | grep aac
faac:  faac: AAC audio encoder
audioparsersbad:  aacparse: AAC audio stream parser
ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
typefindfunctions: adts_mpeg_stream: aac


On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht
<[hidden email]> wrote:
>
> Can you attach the AAC file which you are not able to play ?
>
> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>
>
>
>
> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>
>> Hi
>>     I try it like Sandeep said, first I install the libfaad-dev
>> through Ubuntu's apt-get.
>> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
>> play m4a file,
>> the error message is just the old one.
>>      and then I installed the gst-plugin-bad, play the m4a file again
>> , I got information
>> like this:
>>
>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>> gst_photography_get_focus_mode
>>
>> Do you know what's wrong here?? thx
>>
>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash <[hidden email]>
>> wrote:
>> >
>> > Hi,
>> >
>> >
>> > michael young wrote:
>> >>
>> >> and HOW I get and install an AAC decoder plugin?? thx.
>> >>
>> >
>> > You can install "faad" plugin present in gst-plugins-bad package or the
>> > "ffdec_aac" which is present
>> > in gst-ffmpeg package.
>> >
>> >
>> > Regards,
>> > Sandeep Prakash
>> > http://sandeepprakash.homeip.net
>> > --
>> > View this message in context:
>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-audio-by-Gstreamer-tp2296882p2298084.html
>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>> >
>> >
>> > ------------------------------------------------------------------------------
>> > This SF.net email is sponsored by Sprint
>> > What will you do first with EVO, the first 4G phone?
>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> > _______________________________________________
>> > gstreamer-devel mailing list
>> > [hidden email]
>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>> >
>>
>>
>> ------------------------------------------------------------------------------
>> This SF.net email is sponsored by Sprint
>> What will you do first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>
>
> --
> Regards,
>
> Sudarshan Bisht
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Zheng, Huan
In reply to this post by michael young
Hi, Young
Maybe you can take a look at this page that I wrote before.
http://www.hydrogenaudio.org/forums/lofiversion/index.php/t65868.html 
there's a short paragraph talking about how to use GStreamer to play AAC file

-----Original Message-----
From: michael young [mailto:[hidden email]]
Sent: Thursday, July 22, 2010 2:00 PM
To: Discussion of the development of GStreamer
Subject: Re: [gst-devel] how to play the AAC audio by Gstreamer?

HI sudarshan:

check the attached file , and the file can play in Mplayer, so I think the file is ok.
and i list the information below:
$ gst-inspect-0.10 | grep aac
faac:  faac: AAC audio encoder
audioparsersbad:  aacparse: AAC audio stream parser
ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
typefindfunctions: adts_mpeg_stream: aac


On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht <[hidden email]> wrote:

>
> Can you attach the AAC file which you are not able to play ?
>
> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>
>
>
>
> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>
>> Hi
>>     I try it like Sandeep said, first I install the libfaad-dev
>> through Ubuntu's apt-get.
>> then I reconfigure the gst-ffmpeg plugin, and installed it, but
>> cannot play m4a file, the error message is just the old one.
>>      and then I installed the gst-plugin-bad, play the m4a file again
>> , I got information like this:
>>
>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>> gst_photography_get_focus_mode
>>
>> Do you know what's wrong here?? thx
>>
>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash
>> <[hidden email]>
>> wrote:
>> >
>> > Hi,
>> >
>> >
>> > michael young wrote:
>> >>
>> >> and HOW I get and install an AAC decoder plugin?? thx.
>> >>
>> >
>> > You can install "faad" plugin present in gst-plugins-bad package or
>> > the "ffdec_aac" which is present in gst-ffmpeg package.
>> >
>> >
>> > Regards,
>> > Sandeep Prakash
>> > http://sandeepprakash.homeip.net
>> > --
>> > View this message in context:
>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-aud
>> > io-by-Gstreamer-tp2296882p2298084.html
>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>> >
>> >
>> > -------------------------------------------------------------------
>> > ----------- This SF.net email is sponsored by Sprint What will you
>> > do first with EVO, the first 4G phone?
>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> > _______________________________________________
>> > gstreamer-devel mailing list
>> > [hidden email]
>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>> >
>>
>>
>> ---------------------------------------------------------------------
>> --------- This SF.net email is sponsored by Sprint What will you do
>> first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>
>
> --
> Regards,
>
> Sudarshan Bisht
>
> ----------------------------------------------------------------------
> -------- This SF.net email is sponsored by Sprint What will you do
> first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>
>

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi sadarshan:
   When I configure gst-bad-plugin,  I got the information like this:

configure: *** Plug-ins with dependencies that will be built:
apexsink
dfbvideosink
dvb
faac
faad

fbdevsink
gstalsa
nassink
sdlvideosink sdlaudiosink
vcdsrc

configure: *** Plug-ins with dependencies that will NOT be built:
acm
amrwbenc
assrender
bz2
cdaudio
celt
cog
dc1394
dirac
directdrawsink
directsoundsrc
divx
dtsdec
flite
gme
gsmenc gsmdec
jack
jp2kdec jp2kenc
kate
ladspa
libmms
lv2
metadata
mimic
modplug
mpeg2enc
mplex
musepack
musicbrainz
mythtvsrc
neonhttpsrc
ofa
osxvideosrc
qtwrapper
resindvd
rsvg
schro
sfsrc sfsink
soundtouch
spc
swfdec
theoraexpdec
timidity
vdpau
vp8
wildmidi
wininet
xvid
zbar

from the information, I guess that the plugin about the aac had been installed, is'n it?



On Thu, Jul 22, 2010 at 3:17 PM, Zheng, Huan <[hidden email]> wrote:
> Hi, Young
> Maybe you can take a look at this page that I wrote before.
> http://www.hydrogenaudio.org/forums/lofiversion/index.php/t65868.html
> there's a short paragraph talking about how to use GStreamer to play AAC file
>
> -----Original Message-----
> From: michael young [mailto:[hidden email]]
> Sent: Thursday, July 22, 2010 2:00 PM
> To: Discussion of the development of GStreamer
> Subject: Re: [gst-devel] how to play the AAC audio by Gstreamer?
>
> HI sudarshan:
>
> check the attached file , and the file can play in Mplayer, so I think the file is ok.
> and i list the information below:
> $ gst-inspect-0.10 | grep aac
> faac:  faac: AAC audio encoder
> audioparsersbad:  aacparse: AAC audio stream parser
> ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
> ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
> typefindfunctions: adts_mpeg_stream: aac
>
>
> On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht <[hidden email]> wrote:
>>
>> Can you attach the AAC file which you are not able to play ?
>>
>> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>>
>>
>>
>>
>> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>>
>>> Hi
>>>     I try it like Sandeep said, first I install the libfaad-dev
>>> through Ubuntu's apt-get.
>>> then I reconfigure the gst-ffmpeg plugin, and installed it, but
>>> cannot play m4a file, the error message is just the old one.
>>>      and then I installed the gst-plugin-bad, play the m4a file again
>>> , I got information like this:
>>>
>>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>>> gst_photography_get_focus_mode
>>>
>>> Do you know what's wrong here?? thx
>>>
>>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash
>>> <[hidden email]>
>>> wrote:
>>> >
>>> > Hi,
>>> >
>>> >
>>> > michael young wrote:
>>> >>
>>> >> and HOW I get and install an AAC decoder plugin?? thx.
>>> >>
>>> >
>>> > You can install "faad" plugin present in gst-plugins-bad package or
>>> > the "ffdec_aac" which is present in gst-ffmpeg package.
>>> >
>>> >
>>> > Regards,
>>> > Sandeep Prakash
>>> > http://sandeepprakash.homeip.net
>>> > --
>>> > View this message in context:
>>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-aud
>>> > io-by-Gstreamer-tp2296882p2298084.html
>>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>>> >
>>> >
>>> > -------------------------------------------------------------------
>>> > ----------- This SF.net email is sponsored by Sprint What will you
>>> > do first with EVO, the first 4G phone?
>>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> > _______________________________________________
>>> > gstreamer-devel mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>> >
>>>
>>>
>>> ---------------------------------------------------------------------
>>> --------- This SF.net email is sponsored by Sprint What will you do
>>> first with EVO, the first 4G phone?
>>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> _______________________________________________
>>> gstreamer-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>>
>> --
>> Regards,
>>
>> Sudarshan Bisht
>>
>> ----------------------------------------------------------------------
>> -------- This SF.net email is sponsored by Sprint What will you do
>> first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht
Yes that means its installed but what you get when you do gst-inspect-0.10 faad ? Did you get any plugin information ? If not then there is some problem in linking libfaad2 library with the plugin.



On Thu, Jul 22, 2010 at 11:36 AM, michael young <[hidden email]> wrote:
Hi sadarshan:
   When I configure gst-bad-plugin,  I got the information like this:

configure: *** Plug-ins with dependencies that will be built:
apexsink
dfbvideosink
dvb
faac
faad

fbdevsink
gstalsa
nassink
sdlvideosink sdlaudiosink
vcdsrc

configure: *** Plug-ins with dependencies that will NOT be built:
acm
amrwbenc
assrender
bz2
cdaudio
celt
cog
dc1394
dirac
directdrawsink
directsoundsrc
divx
dtsdec
flite
gme
gsmenc gsmdec
jack
jp2kdec jp2kenc
kate
ladspa
libmms
lv2
metadata
mimic
modplug
mpeg2enc
mplex
musepack
musicbrainz
mythtvsrc
neonhttpsrc
ofa
osxvideosrc
qtwrapper
resindvd
rsvg
schro
sfsrc sfsink
soundtouch
spc
swfdec
theoraexpdec
timidity
vdpau
vp8
wildmidi
wininet
xvid
zbar

from the information, I guess that the plugin about the aac had been installed, is'n it?



On Thu, Jul 22, 2010 at 3:17 PM, Zheng, Huan <[hidden email]> wrote:
> Hi, Young
> Maybe you can take a look at this page that I wrote before.
> http://www.hydrogenaudio.org/forums/lofiversion/index.php/t65868.html
> there's a short paragraph talking about how to use GStreamer to play AAC file
>
> -----Original Message-----
> From: michael young [mailto:[hidden email]]
> Sent: Thursday, July 22, 2010 2:00 PM
> To: Discussion of the development of GStreamer
> Subject: Re: [gst-devel] how to play the AAC audio by Gstreamer?
>
> HI sudarshan:
>
> check the attached file , and the file can play in Mplayer, so I think the file is ok.
> and i list the information below:
> $ gst-inspect-0.10 | grep aac
> faac:  faac: AAC audio encoder
> audioparsersbad:  aacparse: AAC audio stream parser
> ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
> ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
> typefindfunctions: adts_mpeg_stream: aac
>
>
> On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht <[hidden email]> wrote:
>>
>> Can you attach the AAC file which you are not able to play ?
>>
>> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>>
>>
>>
>>
>> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>>
>>> Hi
>>>     I try it like Sandeep said, first I install the libfaad-dev
>>> through Ubuntu's apt-get.
>>> then I reconfigure the gst-ffmpeg plugin, and installed it, but
>>> cannot play m4a file, the error message is just the old one.
>>>      and then I installed the gst-plugin-bad, play the m4a file again
>>> , I got information like this:
>>>
>>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>>> gst_photography_get_focus_mode
>>>
>>> Do you know what's wrong here?? thx
>>>
>>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash
>>> <[hidden email]>
>>> wrote:
>>> >
>>> > Hi,
>>> >
>>> >
>>> > michael young wrote:
>>> >>
>>> >> and HOW I get and install an AAC decoder plugin?? thx.
>>> >>
>>> >
>>> > You can install "faad" plugin present in gst-plugins-bad package or
>>> > the "ffdec_aac" which is present in gst-ffmpeg package.
>>> >
>>> >
>>> > Regards,
>>> > Sandeep Prakash
>>> > http://sandeepprakash.homeip.net
>>> > --
>>> > View this message in context:
>>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-aud
>>> > io-by-Gstreamer-tp2296882p2298084.html
>>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>>> >
>>> >
>>> > -------------------------------------------------------------------
>>> > ----------- This SF.net email is sponsored by Sprint What will you
>>> > do first with EVO, the first 4G phone?
>>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> > _______________________________________________
>>> > gstreamer-devel mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>> >
>>>
>>>
>>> ---------------------------------------------------------------------
>>> --------- This SF.net email is sponsored by Sprint What will you do
>>> first with EVO, the first 4G phone?
>>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> _______________________________________________
>>> gstreamer-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>>
>> --
>> Regards,
>>
>> Sudarshan Bisht
>>
>> ----------------------------------------------------------------------
>> -------- This SF.net email is sponsored by Sprint What will you do
>> first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi sadarshan :
    I got information like this :

$ gst-inspect-0.10 faad
Factory Details:
  Long name: AAC audio decoder
  Class: Codec/Decoder/Audio
  Description: Free MPEG-2/4 AAC decoder
  Author(s): Ronald Bultje <[hidden email]>
  Rank: primary (256)

Plugin Details:
  Name: faad
  Description: Free AAC Decoder (FAAD)
  Filename: /usr/local/lib/gstreamer-0.10/libgstfaad.so
  Version: 0.10.19
  License: GPL
  Source module: gst-plugins-bad
  Binary package: GStreamer Bad Plug-ins source release
  Origin URL: Unknown package origin

GObject
 +----GstObject
       +----GstElement
             +----GstFaad

Pad Templates:
  SRC template: 'src'
    Availability: Always
    Capabilities:
      audio/x-raw-int
             endianness: 1234
                 signed: true
                  width: 16
                  depth: 16
                   rate: [ 8000, 96000 ]
               channels: [ 1, 8 ]

  SINK template: 'sink'
    Availability: Always
    Capabilities:
      audio/mpeg
            mpegversion: { 2, 4 }


Element Flags:
  no flags set

Element Implementation:
  Has change_state() function: gst_faad_change_state
  Has custom save_thyself() function: gst_element_save_thyself
  Has custom restore_thyself() function: gst_element_restore_thyself

Element has no clocking capabilities.
Element has no indexing capabilities.
Element has no URI handling capabilities.

Pads:
  SRC: 'src'
    Implementation:
      Has custom eventfunc(): gst_faad_src_event
      Has custom queryfunc(): gst_faad_src_query
    Pad Template: 'src'
  SINK: 'sink'
    Implementation:
      Has chainfunc(): gst_faad_chain
      Has custom eventfunc(): gst_faad_sink_event
    Pad Template: 'sink'

Element Properties:
  name                : The name of the object
                        flags: readable, writable
                        String. Default: null Current: "faad0"


On Thu, Jul 22, 2010 at 5:20 PM, sudarshan bisht <[hidden email]> wrote:
Yes that means its installed but what you get when you do gst-inspect-0.10 faad ? Did you get any plugin information ? If not then there is some problem in linking libfaad2 library with the plugin.



On Thu, Jul 22, 2010 at 11:36 AM, michael young <[hidden email]> wrote:
Hi sadarshan:
   When I configure gst-bad-plugin,  I got the information like this:

configure: *** Plug-ins with dependencies that will be built:
apexsink
dfbvideosink
dvb
faac
faad

fbdevsink
gstalsa
nassink
sdlvideosink sdlaudiosink
vcdsrc

configure: *** Plug-ins with dependencies that will NOT be built:
acm
amrwbenc
assrender
bz2
cdaudio
celt
cog
dc1394
dirac
directdrawsink
directsoundsrc
divx
dtsdec
flite
gme
gsmenc gsmdec
jack
jp2kdec jp2kenc
kate
ladspa
libmms
lv2
metadata
mimic
modplug
mpeg2enc
mplex
musepack
musicbrainz
mythtvsrc
neonhttpsrc
ofa
osxvideosrc
qtwrapper
resindvd
rsvg
schro
sfsrc sfsink
soundtouch
spc
swfdec
theoraexpdec
timidity
vdpau
vp8
wildmidi
wininet
xvid
zbar

from the information, I guess that the plugin about the aac had been installed, is'n it?



On Thu, Jul 22, 2010 at 3:17 PM, Zheng, Huan <[hidden email]> wrote:
> Hi, Young
> Maybe you can take a look at this page that I wrote before.
> http://www.hydrogenaudio.org/forums/lofiversion/index.php/t65868.html
> there's a short paragraph talking about how to use GStreamer to play AAC file
>
> -----Original Message-----
> From: michael young [mailto:[hidden email]]
> Sent: Thursday, July 22, 2010 2:00 PM
> To: Discussion of the development of GStreamer
> Subject: Re: [gst-devel] how to play the AAC audio by Gstreamer?
>
> HI sudarshan:
>
> check the attached file , and the file can play in Mplayer, so I think the file is ok.
> and i list the information below:
> $ gst-inspect-0.10 | grep aac
> faac:  faac: AAC audio encoder
> audioparsersbad:  aacparse: AAC audio stream parser
> ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
> ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
> typefindfunctions: adts_mpeg_stream: aac
>
>
> On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht <[hidden email]> wrote:
>>
>> Can you attach the AAC file which you are not able to play ?
>>
>> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>>
>>
>>
>>
>> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>>
>>> Hi
>>>     I try it like Sandeep said, first I install the libfaad-dev
>>> through Ubuntu's apt-get.
>>> then I reconfigure the gst-ffmpeg plugin, and installed it, but
>>> cannot play m4a file, the error message is just the old one.
>>>      and then I installed the gst-plugin-bad, play the m4a file again
>>> , I got information like this:
>>>
>>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>>> gst_photography_get_focus_mode
>>>
>>> Do you know what's wrong here?? thx
>>>
>>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash
>>> <[hidden email]>
>>> wrote:
>>> >
>>> > Hi,
>>> >
>>> >
>>> > michael young wrote:
>>> >>
>>> >> and HOW I get and install an AAC decoder plugin?? thx.
>>> >>
>>> >
>>> > You can install "faad" plugin present in gst-plugins-bad package or
>>> > the "ffdec_aac" which is present in gst-ffmpeg package.
>>> >
>>> >
>>> > Regards,
>>> > Sandeep Prakash
>>> > http://sandeepprakash.homeip.net
>>> > --
>>> > View this message in context:
>>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-aud
>>> > io-by-Gstreamer-tp2296882p2298084.html
>>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>>> >
>>> >
>>> > -------------------------------------------------------------------
>>> > ----------- This SF.net email is sponsored by Sprint What will you
>>> > do first with EVO, the first 4G phone?
>>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> > _______________________________________________
>>> > gstreamer-devel mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>> >
>>>
>>>
>>> ---------------------------------------------------------------------
>>> --------- This SF.net email is sponsored by Sprint What will you do
>>> first with EVO, the first 4G phone?
>>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> _______________________________________________
>>> gstreamer-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>>
>> --
>> Regards,
>>
>> Sudarshan Bisht
>>
>> ----------------------------------------------------------------------
>> -------- This SF.net email is sponsored by Sprint What will you do
>> first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>


------------------------------------------------------------------------------

This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Edward Hervey
In reply to this post by michael young
Hi,

  Please refrain from mailing such big attachments in the future.

  Edward


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Tim-Philipp Müller-2
In reply to this post by michael young
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht
In reply to this post by michael young
This shows you have installed faad plugin successfully. I don't have any idea why its not working .

But you can try following combinations ;

gst-launch filesrc location=filename.aac ! decodebin ! audioconvert ! alsasink

gst-launch filesrc location=filename.aac ! decodebin2 ! audioconvert ! alsasink

gst-launch filesrc location=filename.aac ! qtdemux ! faad ! audioconvert ! alsasink

gst-launch filesrc location =filename.aac ! decodebin ! faad ! audioconvert ! alsasink

gst-launch filesrc location =filename.aac ! decodebin2 ! faad ! audioconvert ! alsasink

 



On Thu, Jul 22, 2010 at 12:31 PM, michael young <[hidden email]> wrote:
Hi sadarshan :
    I got information like this :

$ gst-inspect-0.10 faad
Factory Details:
  Long name: AAC audio decoder
  Class: Codec/Decoder/Audio
  Description: Free MPEG-2/4 AAC decoder
  Author(s): Ronald Bultje <[hidden email]>
  Rank: primary (256)

Plugin Details:
  Name: faad
  Description: Free AAC Decoder (FAAD)
  Filename: /usr/local/lib/gstreamer-0.10/libgstfaad.so
  Version: 0.10.19
  License: GPL
  Source module: gst-plugins-bad
  Binary package: GStreamer Bad Plug-ins source release
  Origin URL: Unknown package origin

GObject
 +----GstObject
       +----GstElement
             +----GstFaad

Pad Templates:
  SRC template: 'src'
    Availability: Always
    Capabilities:
      audio/x-raw-int
             endianness: 1234
                 signed: true
                  width: 16
                  depth: 16
                   rate: [ 8000, 96000 ]
               channels: [ 1, 8 ]

  SINK template: 'sink'
    Availability: Always
    Capabilities:
      audio/mpeg
            mpegversion: { 2, 4 }


Element Flags:
  no flags set

Element Implementation:
  Has change_state() function: gst_faad_change_state
  Has custom save_thyself() function: gst_element_save_thyself
  Has custom restore_thyself() function: gst_element_restore_thyself

Element has no clocking capabilities.
Element has no indexing capabilities.
Element has no URI handling capabilities.

Pads:
  SRC: 'src'
    Implementation:
      Has custom eventfunc(): gst_faad_src_event
      Has custom queryfunc(): gst_faad_src_query
    Pad Template: 'src'
  SINK: 'sink'
    Implementation:
      Has chainfunc(): gst_faad_chain
      Has custom eventfunc(): gst_faad_sink_event
    Pad Template: 'sink'

Element Properties:
  name                : The name of the object
                        flags: readable, writable
                        String. Default: null Current: "faad0"


On Thu, Jul 22, 2010 at 5:20 PM, sudarshan bisht <[hidden email]> wrote:
Yes that means its installed but what you get when you do gst-inspect-0.10 faad ? Did you get any plugin information ? If not then there is some problem in linking libfaad2 library with the plugin.



On Thu, Jul 22, 2010 at 11:36 AM, michael young <[hidden email]> wrote:
Hi sadarshan:
   When I configure gst-bad-plugin,  I got the information like this:

configure: *** Plug-ins with dependencies that will be built:
apexsink
dfbvideosink
dvb
faac
faad

fbdevsink
gstalsa
nassink
sdlvideosink sdlaudiosink
vcdsrc

configure: *** Plug-ins with dependencies that will NOT be built:
acm
amrwbenc
assrender
bz2
cdaudio
celt
cog
dc1394
dirac
directdrawsink
directsoundsrc
divx
dtsdec
flite
gme
gsmenc gsmdec
jack
jp2kdec jp2kenc
kate
ladspa
libmms
lv2
metadata
mimic
modplug
mpeg2enc
mplex
musepack
musicbrainz
mythtvsrc
neonhttpsrc
ofa
osxvideosrc
qtwrapper
resindvd
rsvg
schro
sfsrc sfsink
soundtouch
spc
swfdec
theoraexpdec
timidity
vdpau
vp8
wildmidi
wininet
xvid
zbar

from the information, I guess that the plugin about the aac had been installed, is'n it?



On Thu, Jul 22, 2010 at 3:17 PM, Zheng, Huan <[hidden email]> wrote:
> Hi, Young
> Maybe you can take a look at this page that I wrote before.
> http://www.hydrogenaudio.org/forums/lofiversion/index.php/t65868.html
> there's a short paragraph talking about how to use GStreamer to play AAC file
>
> -----Original Message-----
> From: michael young [mailto:[hidden email]]
> Sent: Thursday, July 22, 2010 2:00 PM
> To: Discussion of the development of GStreamer
> Subject: Re: [gst-devel] how to play the AAC audio by Gstreamer?
>
> HI sudarshan:
>
> check the attached file , and the file can play in Mplayer, so I think the file is ok.
> and i list the information below:
> $ gst-inspect-0.10 | grep aac
> faac:  faac: AAC audio encoder
> audioparsersbad:  aacparse: AAC audio stream parser
> ffmpeg:  ffdec_aac: FFmpeg Advanced Audio Coding decoder
> ffmpeg:  ffenc_aac: FFmpeg Advanced Audio Coding encoder
> typefindfunctions: adts_mpeg_stream: aac
>
>
> On Thu, Jul 22, 2010 at 1:32 PM, sudarshan bisht <[hidden email]> wrote:
>>
>> Can you attach the AAC file which you are not able to play ?
>>
>> One more thing when you do "gst-inspect-0.10 | grep aac" what you get .
>>
>>
>>
>>
>> On Thu, Jul 22, 2010 at 10:34 AM, michael young <[hidden email]> wrote:
>>>
>>> Hi
>>>     I try it like Sandeep said, first I install the libfaad-dev
>>> through Ubuntu's apt-get.
>>> then I reconfigure the gst-ffmpeg plugin, and installed it, but
>>> cannot play m4a file, the error message is just the old one.
>>>      and then I installed the gst-plugin-bad, play the m4a file again
>>> , I got information like this:
>>>
>>> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
>>> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
>>> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
>>> gst_photography_get_focus_mode
>>>
>>> Do you know what's wrong here?? thx
>>>
>>> On Thu, Jul 22, 2010 at 11:19 AM, Sandeep Prakash
>>> <[hidden email]>
>>> wrote:
>>> >
>>> > Hi,
>>> >
>>> >
>>> > michael young wrote:
>>> >>
>>> >> and HOW I get and install an AAC decoder plugin?? thx.
>>> >>
>>> >
>>> > You can install "faad" plugin present in gst-plugins-bad package or
>>> > the "ffdec_aac" which is present in gst-ffmpeg package.
>>> >
>>> >
>>> > Regards,
>>> > Sandeep Prakash
>>> > http://sandeepprakash.homeip.net
>>> > --
>>> > View this message in context:
>>> > http://gstreamer-devel.966125.n4.nabble.com/how-to-play-the-AAC-aud
>>> > io-by-Gstreamer-tp2296882p2298084.html
>>> > Sent from the GStreamer-devel mailing list archive at Nabble.com.
>>> >
>>> >
>>> > -------------------------------------------------------------------
>>> > ----------- This SF.net email is sponsored by Sprint What will you
>>> > do first with EVO, the first 4G phone?
>>> > Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> > _______________________________________________
>>> > gstreamer-devel mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>> >
>>>
>>>
>>> ---------------------------------------------------------------------
>>> --------- This SF.net email is sponsored by Sprint What will you do
>>> first with EVO, the first 4G phone?
>>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>>> _______________________________________________
>>> gstreamer-devel mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>>
>> --
>> Regards,
>>
>> Sudarshan Bisht
>>
>> ----------------------------------------------------------------------
>> -------- This SF.net email is sponsored by Sprint What will you do
>> first with EVO, the first 4G phone?
>> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>>
>>
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by Sprint
> What will you do first with EVO, the first 4G phone?
> Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
>


------------------------------------------------------------------------------

This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------

This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
In reply to this post by Tim-Philipp Müller-2
Hi Tim and Edward:
    I am sorry about sending so big file to mail list, and I won't do it again, I promise .

On Thu, Jul 22, 2010 at 5:53 PM, Tim-Philipp Müller <[hidden email]> wrote:
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi sudarshan:
    I don't have the alsasink plugin, and can  I replace it by osssink ?  

On Thu, Jul 22, 2010 at 6:05 PM, michael young <[hidden email]> wrote:
Hi Tim and Edward:
    I am sorry about sending so big file to mail list, and I won't do it again, I promise .


On Thu, Jul 22, 2010 at 5:53 PM, Tim-Philipp Müller <[hidden email]> wrote:
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

michael young
Hi Tim:
   thx for you suggestion, and I install the Gstreamer from resource , there is some reason,
I want to learn more about the Gstreamer, so I want to find the reason why I can't play aac

On Thu, Jul 22, 2010 at 6:08 PM, michael young <[hidden email]> wrote:
Hi sudarshan:
    I don't have the alsasink plugin, and can  I replace it by osssink ?  


On Thu, Jul 22, 2010 at 6:05 PM, michael young <[hidden email]> wrote:
Hi Tim and Edward:
    I am sorry about sending so big file to mail list, and I won't do it again, I promise .


On Thu, Jul 22, 2010 at 5:53 PM, Tim-Philipp Müller <[hidden email]> wrote:
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht
In reply to this post by michael young
Yes , you can .

On Thu, Jul 22, 2010 at 1:08 PM, michael young <[hidden email]> wrote:
Hi sudarshan:
    I don't have the alsasink plugin, and can  I replace it by osssink ?  


On Thu, Jul 22, 2010 at 6:05 PM, michael young <[hidden email]> wrote:
Hi Tim and Edward:
    I am sorry about sending so big file to mail list, and I won't do it again, I promise .


On Thu, Jul 22, 2010 at 5:53 PM, Tim-Philipp Müller <[hidden email]> wrote:
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: how to play the AAC audio by Gstreamer?

Sudarshan Bisht
Hi Michael ,

I could play this aac stream , using playbin , decodebin and qtdemux + faad combination. I  installed all the latest gstreamer packages and libfaad ( using apt-get libfaad-dev ) .



On Thu, Jul 22, 2010 at 11:37 AM, sudarshan bisht <[hidden email]> wrote:
Yes , you can .

On Thu, Jul 22, 2010 at 1:08 PM, michael young <[hidden email]> wrote:
Hi sudarshan:
    I don't have the alsasink plugin, and can  I replace it by osssink ?  


On Thu, Jul 22, 2010 at 6:05 PM, michael young <[hidden email]> wrote:
Hi Tim and Edward:
    I am sorry about sending so big file to mail list, and I won't do it again, I promise .


On Thu, Jul 22, 2010 at 5:53 PM, Tim-Philipp Müller <[hidden email]> wrote:
On Thu, 2010-07-22 at 13:04 +0800, michael young wrote:

>      I try it like Sandeep said, first I install the libfaad-dev
> through Ubuntu's apt-get.
> then I reconfigure the gst-ffmpeg plugin, and installed it, but cannot
> play m4a file,
> the error message is just the old one.
>       and then I installed the gst-plugin-bad, play the m4a file again
> , I got information
> like this:
>
> (gst-plugin-scanner:18537): GStreamer-WARNING **: Failed to load
> plugin '/usr/local/lib/gstreamer-0.10/libgstcamerabin.so':
> /usr/local/lib/gstreamer-0.10/libgstcamerabin.so: undefined symbol:
> gst_photography_get_focus_mode
>
> Do you know what's wrong here?? thx

Please don't install GStreamer from source. Ignore anyone who tells you
that that's what you should do.

GStreamer installed from source into /usr/local/ is going to conflict
with your GStreamer installed from packages, it's impossible to help you
with such a setup. It also breaks other things like the automatic codec
installation that comes by default with ubuntu and other distros.

I would strongly recommend you uninstall all GStreamer plugins and
libraries that you have installed into /usr/local/*. The easiest way to
do that is to run 'sudo make uninstall' in the source tree where you
previously typed 'make install'.

Have you tried playing your file in totem? It should pop up a dialog
that will search for the missing plugins and hopefully install them
(well, that's before you messed up your system by installing stuff from
source).

gstreamer0.10-plugins-bad is the package you need as far as I know, but
it seems you have other problems (ie. gstreamer installed from source
into /usr/local/*).

Cheers
 -Tim

PS: also, please don't send large attachements to mailing list


------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel



------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel




--
Regards,

Sudarshan Bisht



--
Regards,

Sudarshan Bisht

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
12