gstreamer error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gstreamer error

arnabsamanta
  Hi ,
        Can any body kindly tell me what this following error is when am running
the pipeline

                filesrc location=/root/data.dat ! queue3 ! filesink
location=/root/frame1.dat

        ERROR :

                (gst-launch-0.10:21350): GStreamer-CRITICAL **: gst_mini_object_unref:
assertion `mini_object->refcount > 0' failed

  Regards,
        ~Arnab


The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments contained in it.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: gstreamer error

michael smith-6-3
On Fri, Oct 24, 2008 at 4:24 AM, arnabsamanta
<[hidden email]> wrote:

>  Hi ,
>        Can any body kindly tell me what this following error is when am running
> the pipeline
>
>                filesrc location=/root/data.dat ! queue3 ! filesink
> location=/root/frame1.dat
>
>        ERROR :
>
>                (gst-launch-0.10:21350): GStreamer-CRITICAL **: gst_mini_object_unref:
> assertion `mini_object->refcount > 0'           failed
>

Presumably in your 'queue3' element, doing some refcounting wrongly.

If you set G_DEBUG=fatal_warnings, then run it in a debugger, you can
track down where this is happening. From there, hopefully you can
track down your plugin bug.

Mike

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel