Quantcast

gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Gottfried Haider
I've been trying to compile the latest GStreamer for the Raspberry Pi
running Raspbian (Debian).

When I try to build gst-ffmpeg, it fails with the message:
GNU assembler not found, install/update gas-preprocessor

I've downloaded gas-preprocessor.pl file [1] and put it in my $PATH,
with the executable flag set. The "test" target in the Makefile also
succeeds with no errors. Still, the initial error message remains when
trying to build gst-ffmpeg.

Any hints?

(I've successfully built different previous versions (e.g. 1.10.1) of
gst-ffmpeg without this dependency on the same setup.)

Thanks
Gottfried

[1] https://github.com/FFmpeg/gas-preprocessor
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Toshick
Hello Gottfried.

Please, look carefully on toolchains you're using. Are you building on RPi or you're using another platform for this?
If you're using RPi, check that you have *as with your toolchains.

Best regards,
Anton.

On Fri, May 12, 2017 at 12:05 PM, Gottfried Haider <[hidden email]> wrote:
I've been trying to compile the latest GStreamer for the Raspberry Pi
running Raspbian (Debian).

When I try to build gst-ffmpeg, it fails with the message:
GNU assembler not found, install/update gas-preprocessor

I've downloaded gas-preprocessor.pl file [1] and put it in my $PATH,
with the executable flag set. The "test" target in the Makefile also
succeeds with no errors. Still, the initial error message remains when
trying to build gst-ffmpeg.

Any hints?

(I've successfully built different previous versions (e.g. 1.10.1) of
gst-ffmpeg without this dependency on the same setup.)

Thanks
Gottfried

[1] https://github.com/FFmpeg/gas-preprocessor
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Gottfried Haider
Hello Anton,

Thanks for your message.

I am building on the Raspberry Pi. Binutils is installed, and I have used the toolchain to compile other packages already (in fact, all of GStreamer but gst-ffmpeg builds successfully).

Any ideas?

Best,
Gottfried

On Fri, May 12, 2017 at 1:12 PM, Anton Pryima <[hidden email]> wrote:
Hello Gottfried.

Please, look carefully on toolchains you're using. Are you building on RPi or you're using another platform for this?
If you're using RPi, check that you have *as with your toolchains.

Best regards,
Anton.

On Fri, May 12, 2017 at 12:05 PM, Gottfried Haider <[hidden email]> wrote:
I've been trying to compile the latest GStreamer for the Raspberry Pi
running Raspbian (Debian).

When I try to build gst-ffmpeg, it fails with the message:
GNU assembler not found, install/update gas-preprocessor

I've downloaded gas-preprocessor.pl file [1] and put it in my $PATH,
with the executable flag set. The "test" target in the Makefile also
succeeds with no errors. Still, the initial error message remains when
trying to build gst-ffmpeg.

Any hints?

(I've successfully built different previous versions (e.g. 1.10.1) of
gst-ffmpeg without this dependency on the same setup.)

Thanks
Gottfried

[1] https://github.com/FFmpeg/gas-preprocessor
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Toshick

On Fri, May 12, 2017 at 2:29 PM, Gottfried Haider <[hidden email]> wrote:
Hello Anton,

Thanks for your message.

I am building on the Raspberry Pi. Binutils is installed, and I have used the toolchain to compile other packages already (in fact, all of GStreamer but gst-ffmpeg builds successfully).

Any ideas?

Best,
Gottfried

On Fri, May 12, 2017 at 1:12 PM, Anton Pryima <[hidden email]> wrote:
Hello Gottfried.

Please, look carefully on toolchains you're using. Are you building on RPi or you're using another platform for this?
If you're using RPi, check that you have *as with your toolchains.

Best regards,
Anton.

On Fri, May 12, 2017 at 12:05 PM, Gottfried Haider <[hidden email]> wrote:
I've been trying to compile the latest GStreamer for the Raspberry Pi
running Raspbian (Debian).

When I try to build gst-ffmpeg, it fails with the message:
GNU assembler not found, install/update gas-preprocessor

I've downloaded gas-preprocessor.pl file [1] and put it in my $PATH,
with the executable flag set. The "test" target in the Makefile also
succeeds with no errors. Still, the initial error message remains when
trying to build gst-ffmpeg.

Any hints?

(I've successfully built different previous versions (e.g. 1.10.1) of
gst-ffmpeg without this dependency on the same setup.)

Thanks
Gottfried

[1] https://github.com/FFmpeg/gas-preprocessor
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Gottfried Haider
Hello Anton,

I have looked this already, but don't see how it relates to my situation as those users seem to be building ffmpeg on macOS with iOS as the target.

Note: I am getting the same error regardless whether I have gas-preprocessor.pl in my path or not.

Appreciate any help clarifying this for me!

Thanks,
Gottfried

On May 12, 2017 13:56, "Anton Pryima" <[hidden email]> wrote:

On Fri, May 12, 2017 at 2:29 PM, Gottfried Haider <[hidden email]> wrote:
Hello Anton,

Thanks for your message.

I am building on the Raspberry Pi. Binutils is installed, and I have used the toolchain to compile other packages already (in fact, all of GStreamer but gst-ffmpeg builds successfully).

Any ideas?

Best,
Gottfried

On Fri, May 12, 2017 at 1:12 PM, Anton Pryima <[hidden email]> wrote:
Hello Gottfried.

Please, look carefully on toolchains you're using. Are you building on RPi or you're using another platform for this?
If you're using RPi, check that you have *as with your toolchains.

Best regards,
Anton.

On Fri, May 12, 2017 at 12:05 PM, Gottfried Haider <[hidden email]> wrote:
I've been trying to compile the latest GStreamer for the Raspberry Pi
running Raspbian (Debian).

When I try to build gst-ffmpeg, it fails with the message:
GNU assembler not found, install/update gas-preprocessor

I've downloaded gas-preprocessor.pl file [1] and put it in my $PATH,
with the executable flag set. The "test" target in the Makefile also
succeeds with no errors. Still, the initial error message remains when
trying to build gst-ffmpeg.

Any hints?

(I've successfully built different previous versions (e.g. 1.10.1) of
gst-ffmpeg without this dependency on the same setup.)

Thanks
Gottfried

[1] https://github.com/FFmpeg/gas-preprocessor
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Gottfried Haider
Some more investigation:


In the config.log I see:

gas-preprocessor.pl -arch arm -as-type -- as -v
unknown as type: '--'
(...)
as: unrecognized option '-_ISOC99_SOURCE'

The first error seems to be caused by $as_type being empty string in
the ffmpeg configure script. Why this is I do not know. If I force the
"-as-type" argument to read "-as-type gas" this will make the first
error disappear, but the error concerning the unrecognized option
remains (and also bites during the actual build).


The output of "as -v" is:

GNU assembler version 2.25 (arm-linux-gnueabihf) using BFD version
(GNU Binutils for Raspbian) 2.25

I am attempting to build FFmpeg on an armv6hf system for this very target.


Ideas?

Gottfried
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Toshick
Hello Gottfried.

Try to remove - and space:
like: -arch arm -as-type -as -v

Best regards,
Anton.

On Mon, May 15, 2017 at 8:13 PM, Gottfried Haider <[hidden email]> wrote:
Some more investigation:


In the config.log I see:

gas-preprocessor.pl -arch arm -as-type -- as -v
unknown as type: '--'
(...)
as: unrecognized option '-_ISOC99_SOURCE'

The first error seems to be caused by $as_type being empty string in
the ffmpeg configure script. Why this is I do not know. If I force the
"-as-type" argument to read "-as-type gas" this will make the first
error disappear, but the error concerning the unrecognized option
remains (and also bites during the actual build).


The output of "as -v" is:

GNU assembler version 2.25 (arm-linux-gnueabihf) using BFD version
(GNU Binutils for Raspbian) 2.25

I am attempting to build FFmpeg on an armv6hf system for this very target.


Ideas?

Gottfried
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gst-ffmpeg on ARM Linux: GNU assembler not found, install/update gas-preprocessor

Gottfried Haider
Hi Anton,

It turns out this is a know bug in gst-libav, the patch for which was
reverted shortly before 1.12:
https://bugzilla.gnome.org/show_bug.cgi?id=694416

Best,
Gottfried

On Mon, May 15, 2017 at 9:17 PM, Anton Pryima <[hidden email]> wrote:

> Hello Gottfried.
>
> Try to remove - and space:
> like: -arch arm -as-type -as -v
>
> Best regards,
> Anton.
>
> On Mon, May 15, 2017 at 8:13 PM, Gottfried Haider
> <[hidden email]> wrote:
>>
>> Some more investigation:
>>
>>
>> In the config.log I see:
>>
>> gas-preprocessor.pl -arch arm -as-type -- as -v
>> unknown as type: '--'
>> (...)
>> as: unrecognized option '-_ISOC99_SOURCE'
>>
>> The first error seems to be caused by $as_type being empty string in
>> the ffmpeg configure script. Why this is I do not know. If I force the
>> "-as-type" argument to read "-as-type gas" this will make the first
>> error disappear, but the error concerning the unrecognized option
>> remains (and also bites during the actual build).
>>
>>
>> The output of "as -v" is:
>>
>> GNU assembler version 2.25 (arm-linux-gnueabihf) using BFD version
>> (GNU Binutils for Raspbian) 2.25
>>
>> I am attempting to build FFmpeg on an armv6hf system for this very target.
>>
>>
>> Ideas?
>>
>> Gottfried
>> _______________________________________________
>> gstreamer-devel mailing list
>> [hidden email]
>> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
>
>
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
>
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Loading...