Yocto Gstreamer Video Problem

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Yocto Gstreamer Video Problem

argprs
Hi
I use Yocto with Qml for my project. I want to use qml video. QML video require gstreamer so i add following packets my yocto image.

gstreamer1.0 \
gstreamer1.0-meta-base \
gstreamer1.0-libav \
gstreamer1.0-omx \
gstreamer1.0-plugins-bad \
gstreamer1.0-plugins-ugly \
gstreamer1.0-plugins-good \
gstreamer1.0-plugins-base \
gstreamer1.0-rtsp-server \
libomxil \

When i play video via QML video i got following error.

Error: "GStreamer encountered a general supporting library error."

When i write " gst-play-1.0 IMG_0003.avi " command in my terminal for use gst player, i got following outputs

Now playing /home/root/IMG_0003.avi
ERROR GStreamer encountered a general supporting library error. for file:///home/root/IMG_0003.avi
ERROR debug information: ../../gst-omx-1.2.0/omx/gstomxvideodec.c(2424): gst_omx_video_dec_handle_frame (): /GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0/GstOMXH264Dec-omxh264dec:omxh264dec-omxh264dec0:
OpenMAX component in error state Insufficient resources (0x80001000)
Reached end of play list.


Where am i mistake ?

Reply | Threaded
Open this post in threaded view
|

Re: Yocto Gstreamer Video Problem

Ronit P Zagade
which command you used to play .avi  file mention full command

On 21-Feb-2017 5:38 PM, "argprs" <[hidden email]> wrote:
Hi
I use Yocto with Qml for my project. I want to use qml video. QML video
require gstreamer so i add following packets my yocto image.

gstreamer1.0 \
gstreamer1.0-meta-base \
gstreamer1.0-libav \
gstreamer1.0-omx \
gstreamer1.0-plugins-bad \
gstreamer1.0-plugins-ugly \
gstreamer1.0-plugins-good \
gstreamer1.0-plugins-base \
gstreamer1.0-rtsp-server \
libomxil \

When i play video via QML video i got following error.

Error: "GStreamer encountered a general supporting library error."

When i write " gst-play-1.0 IMG_0003.avi " command in my terminal for use
gst player, i got following outputs

Now playing /home/root/IMG_0003.avi
ERROR GStreamer encountered a general supporting library error. for
file:///home/root/IMG_0003.avi
ERROR debug information: ../../gst-omx-1.2.0/omx/gstomxvideodec.c(2424):
gst_omx_video_dec_handle_frame ():
/GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0/GstOMXH264Dec-omxh264dec:omxh264dec-omxh264dec0:
OpenMAX component in error state Insufficient resources (0x80001000)
Reached end of play list.


Where am i mistake ?





--
View this message in context: http://gstreamer-devel.966125.n4.nabble.com/Yocto-Gstreamer-Video-Problem-tp4681970.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Yocto Gstreamer Video Problem

argprs
i use only "gst-play-1.0 IMG_0003.avi"
Reply | Threaded
Open this post in threaded view
|

Re: Yocto Gstreamer Video Problem

Ronit P Zagade
i dont think its worked command where is your sink decoder n all


On 21-Feb-2017 9:17 PM, "argprs" <[hidden email]> wrote:
i use only "gst-play-1.0 IMG_0003.avi"



--
View this message in context: http://gstreamer-devel.966125.n4.nabble.com/Yocto-Gstreamer-Video-Problem-tp4681970p4681975.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Yocto Gstreamer Video Problem

argprs
Sorry man, i am very new this issue. I dont know sink decoder. When i run "gst-play-1.0 IMG_0003.avi" command, i only try to play video via gstreamer.

What am i doing play video or get messages about this status via gstreamer ?
Reply | Threaded
Open this post in threaded view
|

Re: Yocto Gstreamer Video Problem

argprs
i solved my problem by add gpu_mem=128 line in config.txt.