Unable to play the video with gst-launch1.0 by command line.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to play the video with gst-launch1.0 by command line.

venkatesh
Hi,
we have tried the below command also as  Tim-Philipp Müller  suggested:
 gst-launch-1.0 playbin uri=file:///path/to/foo.mkv

but, still i am unable to play the video.

please find the below results:

root@localhost:~/home# gst-launch-1.0 playbin
uri=file:///root/home/video2.mp4
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
[INFO]  bitstreamMode 1, chromaInterleave 0, mapType 0, tiled2LinearEnable 0

Note: After the above statements, nothing is monitored and processing
happens continuously.

Actually i am new to this Gstreamer and may i know the how to play the video
by using GStreamer?


Thanks,
Venkatesh Marella



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Unable to play the video with gst-launch1.0 by command line.

ShilVin
Hi

>> [INFO]  bitstreamMode 1, chromaInterleave 0, mapType 0,
>> tiled2LinearEnable 0
I don't know what above lines means.

>> gst-launch-1.0 playbin uri=file:///path/to/foo.mkv

The above pipeline is correct and don't see any problem.

May be desktop installation is missing in your machine so not able to
display the decoded video.
Enable debug logs it may hint you some thing.
gst-launch-1.0 playbin uri=file:///path/to/foo.mkv  --gst-debug=2 .



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Unable to play the video with gst-launch1.0 by command line.

venkatesh
Hi,
we have enabled the debug log and tried with below command and found some
errors.

gst-launch-1.0 playbin uri=file:///path/to/foo.mkv  --gst-debug=2 .

please find the attached document and please help us needfully.


gst_log.txt
<http://gstreamer-devel.966125.n4.nabble.com/file/t378391/gst_log.txt>  


Thanks,
Venkatesh Marella



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel