Text relocation in Android gstreamer library: error compilation after API=23

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Text relocation in Android gstreamer library: error compilation after API=23

Grégoire Gentil
I have an Android gstreamer library. It was initially compiled with
version 1.5.1 on API 19 or 21. I had a warning message stating that
there are some text relocations but there was no problem.

I upgraded to API 23, NDK revsion 10e as well as gstreamer 1.6. If I use

<uses-sdk
     android:minSdkVersion="14"
     android:targetSdkVersion="22" />

in the manifest, everything works fine.

If I use

<uses-sdk
     android:minSdkVersion="14"
     android:targetSdkVersion="23" />

it still compiles but it doesn't work at run-time. The device says that
it can't find the library though it's in the apk file.

Before the upgrade, I tried to add -fPIC but I was still getting the
warning. I was unsure if the relocation was in my code or if it was in
the Android gstreamer binaries.

Since the upgrade to gstreamer 1.6, I don't get any more warning or
error during compilation. But now it fails at run-time.

I'm wondering if the gstreamer binaries had or have some text
relocation. I don't think that I'm doing anything special in my
gstreamer code that would trigger a relocation but I'm unsure.

Here is a couple of link:

http://stackoverflow.com/questions/34373984/missing-library-for-android-6-x-app-when-compiling-with-targetsdkversion-23-32

https://code.google.com/p/android-developer-preview/issues/detail?id=3028

Any idea?

Grégoire
_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Text relocation in Android gstreamer library: error compilation after API=23

stic
Text relocation is caused by libav and x264 plugins. If you don't need them and remove it you won't have text relocation anymore, and your library will be allowed again when targeting android-23.
See following bug report: https://bugzilla.gnome.org/show_bug.cgi?id=742633
But you could also keep targeting android-22 so you won't be annoyed by this.

----- Mail original -----
De: "Gregoire Gentil" <[hidden email]>
À: [hidden email]
Envoyé: Lundi 21 Décembre 2015 20:43:03
Objet: Text relocation in Android gstreamer library: error compilation after API=23

I have an Android gstreamer library. It was initially compiled with
version 1.5.1 on API 19 or 21. I had a warning message stating that
there are some text relocations but there was no problem.

I upgraded to API 23, NDK revsion 10e as well as gstreamer 1.6. If I use

<uses-sdk
     android:minSdkVersion="14"
     android:targetSdkVersion="22" />

in the manifest, everything works fine.

If I use

<uses-sdk
     android:minSdkVersion="14"
     android:targetSdkVersion="23" />

it still compiles but it doesn't work at run-time. The device says that
it can't find the library though it's in the apk file.

Before the upgrade, I tried to add -fPIC but I was still getting the
warning. I was unsure if the relocation was in my code or if it was in
the Android gstreamer binaries.

Since the upgrade to gstreamer 1.6, I don't get any more warning or
error during compilation. But now it fails at run-time.

I'm wondering if the gstreamer binaries had or have some text
relocation. I don't think that I'm doing anything special in my
gstreamer code that would trigger a relocation but I'm unsure.

Here is a couple of link:

http://stackoverflow.com/questions/34373984/missing-library-for-android-6-x-app-when-compiling-with-targetsdkversion-23-32

https://code.google.com/p/android-developer-preview/issues/detail?id=3028

Any idea?

Grégoire
_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Text relocation in Android gstreamer library: error compilation after API=23

Grégoire Gentil
I'm fine to keep android-22 but I think that the importance of this bug
should be raised up because Android-23 doesn't consider it any more as a
warning but as an error and it prevents from working,

Grégoire



On 12/21/2015 01:57 PM, [hidden email] wrote:

> Text relocation is caused by libav and x264 plugins. If you don't need them and remove it you won't have text relocation anymore, and your library will be allowed again when targeting android-23.
> See following bug report: https://bugzilla.gnome.org/show_bug.cgi?id=742633
> But you could also keep targeting android-22 so you won't be annoyed by this.
>
> ----- Mail original -----
> De: "Gregoire Gentil" <[hidden email]>
> À: [hidden email]
> Envoyé: Lundi 21 Décembre 2015 20:43:03
> Objet: Text relocation in Android gstreamer library: error compilation after API=23
>
> I have an Android gstreamer library. It was initially compiled with
> version 1.5.1 on API 19 or 21. I had a warning message stating that
> there are some text relocations but there was no problem.
>
> I upgraded to API 23, NDK revsion 10e as well as gstreamer 1.6. If I use
>
> <uses-sdk
>       android:minSdkVersion="14"
>       android:targetSdkVersion="22" />
>
> in the manifest, everything works fine.
>
> If I use
>
> <uses-sdk
>       android:minSdkVersion="14"
>       android:targetSdkVersion="23" />
>
> it still compiles but it doesn't work at run-time. The device says that
> it can't find the library though it's in the apk file.
>
> Before the upgrade, I tried to add -fPIC but I was still getting the
> warning. I was unsure if the relocation was in my code or if it was in
> the Android gstreamer binaries.
>
> Since the upgrade to gstreamer 1.6, I don't get any more warning or
> error during compilation. But now it fails at run-time.
>
> I'm wondering if the gstreamer binaries had or have some text
> relocation. I don't think that I'm doing anything special in my
> gstreamer code that would trigger a relocation but I'm unsure.
>
> Here is a couple of link:
>
> http://stackoverflow.com/questions/34373984/missing-library-for-android-6-x-app-when-compiling-with-targetsdkversion-23-32
>
> https://code.google.com/p/android-developer-preview/issues/detail?id=3028
>
> Any idea?
>
> Grégoire
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
>
_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Text relocation in Android gstreamer library: error compilation after API=23

Sebastian Dröge-3
On Mo, 2015-12-21 at 14:51 -0800, Gregoire Gentil wrote:
> I'm fine to keep android-22 but I think that the importance of this
> bug should be raised up because Android-23 doesn't consider it any
> more as a warning but as an error and it prevents from working,

It should be fixed at some point indeed, but so far nobody showed much
interest in fixing it and it's also not really urgent yet. If you want
to help with that, as a first step getting in touch with the ffmpeg and
x264 projects would be good.


It's going to be another few years until people seriously start
targetting Android API 23. That's maybe 0.1% of the devices out there
that currently support it and you probably don't want to limit your app
to those.

--
Sebastian Dröge, Centricular Ltd · http://www.centricular.com


_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

signature.asc (968 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Text relocation in Android gstreamer library: error compilation after API=23

matrixy
Anyone managed to fix this?
i'm getting this issue on x86 devices but not on arm devices.




--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel