Stutter in RTP stream over LAN

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Stutter in RTP stream over LAN

Nihit Mody
Hi All,

I have enjoyed using G-Streamer1.0 but have hit a snag in being able to smoothly stream data over a wireless LAN. My goal is to stream smoothly in realtime. I am currently using JPEG encoding to reduce latency.

My sender pipeline:

gst-launch-1.0 v4l2src device="/dev/video0" do-timestamp=true ! video/x-raw,width=1920,height=1080,framerate=60/1 ! jpegenc ! rtpjpegpay ! multiudpsink clients=192.168.0.x:5000

My receiver pipeline:

gst-launch-1.0 udpsrc port=5000 ! application/x-rtp,encoding-name=JPEG,payload=26 ! rtpjpegdepay ! jpegdec ! videoconvert ! appsink

I have tried with/without do-timestamp in the sender pipeline. The do-timestamp seems to help with the video stuttering every 30 to 45 seconds versus every 15 seconds without. I have also tried rtpjitterbuffer on the receiver side and no matter what the latency property I add it doesn't seem to help the video stuttering issue. I have checked the sender side to ensure v4l2src isn't the cause of the problem by running autovideosink in a seperate thread using the tee and queue elements. Do you have any suggestions on how I can fix this stuttering issue on a high bandwith local area network connection?

The same issue occurs even at lower resolutions.

Thanks!



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel