Re: Playing video

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Playing video

V.Murugadoss
Hi Daiane,
Thanks for the reply. I tried to run the video with the command,

mx27# gst-launch playbin uri=file:///mnt/nfs/Toyata_Human_Touch.mpg
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
** Message: don't know how to handle video/mpeg, mpegversion=(int)1, systemstream=(boolean)false
configure_write_channel, stream_id is 0
hw free: SSI 1
codec_reset_settings function is called
Write Release Called
codec_reset_settings function is called
Read Release called
snd_card_mxc_audio_playback_close
configure_write_channel, stream_id is 0.
playback prepare snd_mxc_audio_playback_prepare
codec_reset_settings function is called
Write Start ioctl function called
PlayerWriteStart function called
HeadPhone_PlayerWrite function called
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "playbin0".
Execution endeplayback prepare snd_mxc_audio_playback_prepare
d after 57502819000 ns.
Settingcodec_reset_settings function is called
 pipeline to PAUSED ...
Write Start ioctl function called
PlayerWriteStart function called
HeadPhone_PlayerWrite function called
Setting pipeline to READY ...
hw free: SSI 1
codec_reset_settings function is called
Write Release Called
addr 12000 and aaa00
codec_reset_settings function is called
Read Release called
hw free: SSI 1
codec_reset_settings function is called
Write Release Called
codec_reset_settings function is called
Read Release called
snd_card_mxc_audio_playback_close
Setting pipeline to NULL ...
FREEING pipeline ...

Now the audio is playing,but i don't get the video. What may be issue? can u help me?

Thank u

Regards
V.Murugadoss



Daiane Angolini wrote:
Basicaly, you will use a command like a simple gstreamer command!

You will find a lot of examples in web.

But, you need a line like this:

gst-launch source ! demux ! decoder ! sink


Daiane


On Wed, 2008-10-22 at 18:09 +0530, murugadoss wrote:
  
Hi Daiane, 
Thanks for the reply. 
I need to test the video in my board using gstreamer. It need to
support all formats of files. 
presently, i need to play Mpeg, mp4 formats. 
Thank u

Regards 
V.Murugadoss



Daiane Angolini wrote: 
    
HellO!

What king of video do you want to play!?

You can see something here:
http://www.imxdev.org/wiki/index.php?title=I.MX27_ADS_Board_Video_GST_Play

But, this page is incomplete. Let me know if you will need some help.


Best regards,


Daiane


  
      


  

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Playing video

Alan Carvalho de Assis
Hi V.Murugadoss

On Wed, Oct 22, 2008 at 12:02 PM, murugadoss <[hidden email]> wrote:

> Hi Daiane,
> Thanks for the reply. I tried to run the video with the command,
>
> mx27# gst-launch playbin uri=file:///mnt/nfs/Toyata_Human_Touch.mpg
> Setting pipeline to PAUSED ...
> Pipeline is PREROLLING ...
> ** Message: don't know how to handle video/mpeg, mpegversion=(int)1,
> systemstream=(boolean)false
> configure_write_channel, stream_id is 0
> hw free: SSI 1
> codec_reset_settings function is called
> Write Release Called
> codec_reset_settings function is called
> Read Release called
> snd_card_mxc_audio_playback_close
> configure_write_channel, stream_id is 0.
> playback prepare snd_mxc_audio_playback_prepare
> codec_reset_settings function is called
> Write Start ioctl function called
> PlayerWriteStart function called
> HeadPhone_PlayerWrite function called
> Pipeline is PREROLLED ...
> Setting pipeline to PLAYING ...
> New clock: GstAudioSinkClock
> Got EOS from element "playbin0".
> Execution endeplayback prepare snd_mxc_audio_playback_prepare
> d after 57502819000 ns.
> Settingcodec_reset_settings function is called
>  pipeline to PAUSED ...
> Write Start ioctl function called
> PlayerWriteStart function called
> HeadPhone_PlayerWrite function called
> Setting pipeline to READY ...
> hw free: SSI 1
> codec_reset_settings function is called
> Write Release Called
> addr 12000 and aaa00
> codec_reset_settings function is called
> Read Release called
> hw free: SSI 1
> codec_reset_settings function is called
> Write Release Called
> codec_reset_settings function is called
> Read Release called
> snd_card_mxc_audio_playback_close
> Setting pipeline to NULL ...
> FREEING pipeline ...
>
> Now the audio is playing,but i don't get the video. What may be issue? can u
> help me?
>

Please verify if you have mpeg decoder plugin installed correctly:
gst-inspect | grep mpeg

> Thank u
>
> Regards
> V.Murugadoss
>

Best Regards,

Alan

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gstreamer-devel