Problems with textoverlay and non-ASCII chars

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with textoverlay and non-ASCII chars

andeb91
Hello, I apologize if I'm posting this in the wrong place.
I'm having a lot of problems using textoverlay plugin with UTF-8 text.
Could someone help me? How can I overlay UTF-8 text in Gstreamer?
Thanks in advance.

Andrea



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with textoverlay and non-ASCII chars

Nicolas Dufresne-5
Le jeudi 21 décembre 2017 à 08:23 -0700, andeb91 a écrit :
> Hello, I apologize if I'm posting this in the wrong place.
> I'm having a lot of problems using textoverlay plugin with UTF-8 text.
> Could someone help me? How can I overlay UTF-8 text in Gstreamer?
> Thanks in advance.

Please, provide information about what you have tried, how it failed
etc. There is not enough context. textoverlay only do UTF-8, nothing
else. This works perfectly or me, on Linux, Fedora 17, GStreamer 1.12,
a perfectly tested installation of Pango.

gst-launch-1.0 videotestsrc ! textoverlay text="Été" ! glimagesink

Nicolas
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems with textoverlay and non-ASCII chars

andeb91
Sorry for the missing information.

I'm working on Windows 10, with GStreamer 1.12.

I've also tested your pipeline and the error is:
/ERROR           GST_PIPELINE grammar.y:454:gst_parse_element_set: could not
set property "text" in element "textoverlay0" to "Été"
[Invalid UTF-8] WARNING: erroneous pipeline: could not set property "text"
in element "textoverlay0" to "\xc9t\xe9"/

I've tested both command line and c++ software application, the error is the
same.

Thanks in advance,

Andrea




--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel