Probl running 2 audio pipelines with the same devices at the same time

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Probl running 2 audio pipelines with the same devices at the same time

Stefano Zuín

Hi,

When trying to run pipeline {alsasrc device="hw:0,0" ! "audio/x-raw,rate=48000" ! audioconvert ! alsasink} for first time, the result is succesfull. With the first pipeline running, I repeat the it in a second pipeline and get ther error device hw:0,0 busy.

Is there any way to run this two pipelines??

hw:0,0 is defined as the default card in asound.conf in order to omit the device definition. Doing that, the two pipelines are in running state but cannot listen anything.

when running a audiotestsrc pipe, there's no problem...


--

Stefano Zuin Castillo
Ingeniero de Software
email: [hidden email]
Tel: +34 93 551 14 94

DEVIMETRIX, S.L.
C/ Llacuna 162, módulo 118
08018 Barcelona (SPAIN)
www.kiversal.com




Este correo electrónico y sus documentos adjuntos contienen información privilegiada, personal y estrictamente confidencial, y está prohibida la copia, reenvío o utilización de la información.
Si usted no es la persona destinataria del presente mensaje, no está autorizada a leerlo, retenerlo o difundirlo.

This e-mail and its attachments are privileged, confidential and contain private information, and any sending, using or copy of its information is prohibited.
Any person other than its intended recipient is not authorised to read, retain or distribute this information.



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel