Multiple pipeline with OpenGL and vaapi elements

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Multiple pipeline with OpenGL and vaapi elements

adrien_sch
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Multiple pipeline with OpenGL and vaapi elements

Matthew Waters
On 20/02/14 06:02, adrien_sch wrote:
> Hello guys,
>
> I wanted to know if it is supported to use openGL and vaapi elements in
> different pipelines ( => with different GMainContext) in a same process.

Ideally, it should work though I haven't tested it.

> The result of my first try is a very buggy program (a lot of SEGFAULT in
> vaapi and opengl, system freeze).

Could you please file a bug about this at
https://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer with a
backtrace and an example program or gst-launch line if possible.
Although your system freezing sounds like an implementation bug lower
than GStreamer.  What hardware/OS is this on?

> What can I do to resolve these issues (if supported) ?
>
> Thx in advance for you help.
>
>
>
>
>
> --
> View this message in context: http://gstreamer-devel.966125.n4.nabble.com/Multiple-pipeline-with-OpenGL-and-vaapi-elements-tp4665379.html
> Sent from the GStreamer-devel mailing list archive at Nabble.com.
>

_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Multiple pipeline with OpenGL and vaapi elements

adrien_sch
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Multiple pipeline with OpenGL and vaapi elements

adrien_sch
CONTENTS DELETED
The author has deleted this message.