Multicast udpsink problems

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Multicast udpsink problems

rgdtx
I am trying to stream H264 video via multicast to several devices I have the
following pipelines:

Server (Windows):

D:\gstreamer\1.0\x86\bin\gst-launch-1.0.exe ksvideosrc device-index=0 !
videorate ! tee name=t ! queue! autovideosink t. ! queue ! videoconvert !
x264enc tune=zerolatency byte-stream=true bitrate=3000 ! rtph264pay !
udpsink port=5700 host=224.0.15.0 auto-multicast=true

Client (Linux):

gst-launch-1.0 udpsrc auto-multicast=true address=224.0.15.0 port=5700 !
"application/x-rtp, payload=127" ! rtph264depay ! avdec_h264 ! videoconvert
! ximagesink

This technically works, but the video quality is utterly unviewable, it
feels like a huge amount of packet loss is happening or something. However
if I use the same client, but transmit with a non-multicast server straight
to the client, it works flawlessly.

Server (Windows):

D:\gstreamer\1.0\x86\bin\gst-launch-1.0.exe ksvideosrc device-index=0 !
videorate ! tee name=t ! queue! autovideosink t. ! queue ! videoconvert !
x264enc tune=zerolatency byte-stream=true bitrate=3000 ! rtph264pay !
udpsink port=5700 host=192.1.1.122


Any suggestions what is going wrong and what I can do to attempt to fix it?






--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Multicast udpsink problems

Arjen Veenhuizen
You should at least include an rtpjitterbuffer element in your client's
pipeline to account for out-of-order packets. Furthermore, throwing in a
queue never hurts as well, e.g.:




--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Multicast udpsink problems

Baby Octopus
In reply to this post by rgdtx
Have you checked if your network switch is able to handle multiple mulicasts?
If unicast is working fine, then it would be beyond gstreamer, most likely
in your network configuration

~BO



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Multicast udpsink problems

Trevor Clarke
Unicast is not working with webm

On Wed, Mar 7, 2018 at 2:16 AM, Baby Octopus <[hidden email]> wrote:
Have you checked if your network switch is able to handle multiple mulicasts?
If unicast is working fine, then it would be beyond gstreamer, most likely
in your network configuration

~BO



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel