Mic on Raspberry Pi - no output from Gstreamer

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Mic on Raspberry Pi - no output from Gstreamer

davepcollins83
I have a RPI with 2 microphones - one is a cheap USB mic and the other an
Adafruit module I2S mix module. They are both working within Alsa, this is
the output from arecord -l:

**** List of CAPTURE Hardware Devices ****
card 1: sndrpisimplecar [snd_rpi_simple_card], device 0:
simple-card_codec_link snd-soc-dummy-dai-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I am testing using a basic Gstreamer pipeline to record to wav (I need to do
something more complex with the stream later but for now I'm just trying to
record a test file). This is my pipeline:

gst-launch-1.0 alsasrc device=plughw:2,0 ! audioamplify amplification=10 !
audioconvert ! wavenc ! filesink location="test.wav"

This works fine and I can record audio. However, when I change to
device=plughw:1,0 I still get a successful console output but the wav file
is silent. However, if I record a short wav using arecord both devices work
fine.

I'd be grateful for any help in debugging this.



--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel