KLV stream not detected

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

KLV stream not detected

Arturo Flores
I have a file that contains two streams: a video stream and a klv stream.  One problem I have encountered is it appears the KLV stream is not being detected when using gstreamer-1.0 .  For example, if I use gst-discoverer-0.10 on this file I get:

...
Done discovering file://somefilewithklv.mpg

Topology:
  container: MPEG-2 Transport Stream
    video: H.264
    unknown: private/klv
...


However, if I use the new gstreamer tool gst-discoverer-1.0, I get:

Done discovering file:///somefilewithklv.mpg

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile)

I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should I be seing the unknown:private/klv stream when using the new gst-discoverer-1.0 ?

Thanks

Arturo


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

jhanksv

It works correctly on 1.15.0.1.  It must be a bug in 14.:

norman:~$ gst-discoverer-1.0 --gst-version
GStreamer Core Library version 1.15.0.1
norman:~$ gst-discoverer-1.0 /data/file.ts
Analyzing file:///data/file.ts
Done discovering file:///data/file.ts

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (High 4:2:2 Profile)
    audio: MPEG-2 AAC
    unknown: meta/x-klv

Properties:
  Duration: 0:00:19.095193925
  Seekable: yes
  Live: no
  Tags:
      language code: en
      audio codec: MPEG-2 AAC
      video codec: H.264

John


On 06/21/2018 01:41 PM, Arturo Flores wrote:
I have a file that contains two streams: a video stream and a klv stream.  One problem I have encountered is it appears the KLV stream is not being detected when using gstreamer-1.0 .  For example, if I use gst-discoverer-0.10 on this file I get:

...

Topology:
  container: MPEG-2 Transport Stream
    video: H.264
    unknown: private/klv
...


However, if I use the new gstreamer tool gst-discoverer-1.0, I get:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile)

I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should I be seing the unknown:private/klv stream when using the new gst-discoverer-1.0 ?

Thanks

Arturo



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Arturo Flores
Thanks, where would I get 1.15.01?  I only see 1.14.01 here: https://gstreamer.freedesktop.org/data/pkg/windows/ .  Is it possible this is working in previous versions (pre 1.14)?

Arturo


On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]> wrote:

It works correctly on 1.15.0.1.  It must be a bug in 14.:

norman:~$ gst-discoverer-1.0 --gst-version
GStreamer Core Library version 1.15.0.1
norman:~$ gst-discoverer-1.0 /data/file.ts
Analyzing file:///data/file.ts
Done discovering file:///data/file.ts

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (High 4:2:2 Profile)
    audio: MPEG-2 AAC
    unknown: meta/x-klv

Properties:
  Duration: 0:00:19.095193925
  Seekable: yes
  Live: no
  Tags:
      language code: en
      audio codec: MPEG-2 AAC
      video codec: H.264

John


On 06/21/2018 01:41 PM, Arturo Flores wrote:
I have a file that contains two streams: a video stream and a klv stream.  One problem I have encountered is it appears the KLV stream is not being detected when using gstreamer-1.0 .  For example, if I use gst-discoverer-0.10 on this file I get:

...

Topology:
  container: MPEG-2 Transport Stream
    video: H.264
    unknown: private/klv
...


However, if I use the new gstreamer tool gst-discoverer-1.0, I get:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile)

I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should I be seing the unknown:private/klv stream when using the new gst-discoverer-1.0 ?

Thanks

Arturo



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Arturo Flores
In reply to this post by jhanksv
btw, I tried downloading a few other versions of gstreamer (1.10, 1.12, 1.13 ), I'm observing the same behavior in those versions too.  Should I be able to detect the KLV stream?

On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]> wrote:

It works correctly on 1.15.0.1.  It must be a bug in 14.:

norman:~$ gst-discoverer-1.0 --gst-version
GStreamer Core Library version 1.15.0.1
norman:~$ gst-discoverer-1.0 /data/file.ts
Analyzing file:///data/file.ts
Done discovering file:///data/file.ts

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (High 4:2:2 Profile)
    audio: MPEG-2 AAC
    unknown: meta/x-klv

Properties:
  Duration: 0:00:19.095193925
  Seekable: yes
  Live: no
  Tags:
      language code: en
      audio codec: MPEG-2 AAC
      video codec: H.264

John


On 06/21/2018 01:41 PM, Arturo Flores wrote:
I have a file that contains two streams: a video stream and a klv stream.  One problem I have encountered is it appears the KLV stream is not being detected when using gstreamer-1.0 .  For example, if I use gst-discoverer-0.10 on this file I get:

...

Topology:
  container: MPEG-2 Transport Stream
    video: H.264
    unknown: private/klv
...


However, if I use the new gstreamer tool gst-discoverer-1.0, I get:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile)

I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should I be seing the unknown:private/klv stream when using the new gst-discoverer-1.0 ?

Thanks

Arturo



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Nicolas Dufresne-5
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :

> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv
Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >  
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Arturo Flores
Hi Nicolas,

The output I've observed in all of the gstreamer1.x versions I've tried (up to 1.14.1) is:

Done discovering file:///somefilewithklv.mpg

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile

John Hanks says he observed the "unknown: meta/x-klv" line in gstreamer 1.15.0.1  .  I don't have that version, and I don't know where to get it.  If you know where to get it, please let me know.

Thanks

Arturo


On Fri, Jun 22, 2018 at 12:53 PM, Nicolas Dufresne <[hidden email]> wrote:
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :
> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv

Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> > 
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Nicolas Dufresne-5


Le ven. 22 juin 2018 16:42, Arturo Flores <[hidden email]> a écrit :
Hi Nicolas,

The output I've observed in all of the gstreamer1.x versions I've tried (up to 1.14.1) is:

Done discovering file:///somefilewithklv.mpg

Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile

John Hanks says he observed the "unknown: meta/x-klv" line in gstreamer 1.15.0.1  .  I don't have that version, and I don't know where to get it.  If you know where to get it, please let me know.

1.15 is not a real version. Odd minor identify development branches. 1.15 is the current development branches, toward next stable branch 1.16. if you can't wait to get a new feature, try and identify the patches that added this feature, and then you can backport into your project.


Thanks

Arturo


On Fri, Jun 22, 2018 at 12:53 PM, Nicolas Dufresne <[hidden email]> wrote:
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :
> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv

Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> > 
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

jhanksv
In reply to this post by Arturo Flores

Sorry for the late response - I've been out of town.

I am running on Linux and did a git update (git pull origin).  The git repository updated to 1.15 a couple of weeks ago.

John


On 06/22/2018 04:36 PM, Arturo Flores wrote:
Hi Nicolas,

The output I've observed in all of the gstreamer1.x versions I've tried (up to 1.14.1) is:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile

John Hanks says he observed the "unknown: meta/x-klv" line in gstreamer 1.15.0.1  .  I don't have that version, and I don't know where to get it.  If you know where to get it, please let me know.

Thanks

Arturo


On Fri, Jun 22, 2018 at 12:53 PM, Nicolas Dufresne <[hidden email]> wrote:
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :
> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv

Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> > 
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel




_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

Arturo Flores
Thanks, would this be the master branch here https://github.com/GStreamer/gstreamer ?

Are nightly windows builds of master available anywhere?  I can figure out how to build it on windows if necessary, but if there is something like a nightly build for windows available somewhere, I would use that option instead.

Arturo


On Tue, Jul 3, 2018 at 6:13 PM, John Hanks <[hidden email]> wrote:

Sorry for the late response - I've been out of town.

I am running on Linux and did a git update (git pull origin).  The git repository updated to 1.15 a couple of weeks ago.

John


On 06/22/2018 04:36 PM, Arturo Flores wrote:
Hi Nicolas,

The output I've observed in all of the gstreamer1.x versions I've tried (up to 1.14.1) is:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile

John Hanks says he observed the "unknown: meta/x-klv" line in gstreamer 1.15.0.1  .  I don't have that version, and I don't know where to get it.  If you know where to get it, please let me know.

Thanks

Arturo


On Fri, Jun 22, 2018 at 12:53 PM, Nicolas Dufresne <[hidden email]> wrote:
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :
> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv

Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> > 
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel




_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: KLV stream not detected

jhanksv

For whatever reason, it looks like I used 

git://anongit.freedesktop.org/git/gstreamer/$module

to grab my initial install and just do 'git pull origin' to get updates.

I found a script from last August that used this as the source and this is also in the gst-plugins-good.doap file in my gst-plugins-good build directory.  I haven't has a need to learn too much a git so I'm not sure how different this might be from what is on github (or how to tell).

John


On 07/04/2018 11:31 AM, Arturo Flores wrote:
Thanks, would this be the master branch here https://github.com/GStreamer/gstreamer ?

Are nightly windows builds of master available anywhere?  I can figure out how to build it on windows if necessary, but if there is something like a nightly build for windows available somewhere, I would use that option instead.

Arturo


On Tue, Jul 3, 2018 at 6:13 PM, John Hanks <[hidden email]> wrote:

Sorry for the late response - I've been out of town.

I am running on Linux and did a git update (git pull origin).  The git repository updated to 1.15 a couple of weeks ago.

John


On 06/22/2018 04:36 PM, Arturo Flores wrote:
Hi Nicolas,

The output I've observed in all of the gstreamer1.x versions I've tried (up to 1.14.1) is:


Topology:
  container: MPEG-2 Transport Stream
    video: H.264 (Baseline Profile

John Hanks says he observed the "unknown: meta/x-klv" line in gstreamer 1.15.0.1  .  I don't have that version, and I don't know where to get it.  If you know where to get it, please let me know.

Thanks

Arturo


On Fri, Jun 22, 2018 at 12:53 PM, Nicolas Dufresne <[hidden email]> wrote:
Le vendredi 22 juin 2018 à 11:22 -0700, Arturo Flores a écrit :
> btw, I tried downloading a few other versions of gstreamer (1.10,
> 1.12, 1.13 ), I'm observing the same behavior in those versions too.
> Should I be able to detect the KLV stream?
>
> On Thu, Jun 21, 2018 at 5:52 PM, John Hanks <[hidden email]>
> wrote:
> > It works correctly on 1.15.0.1.  It must be a bug in 14.:
> > norman:~$ gst-discoverer-1.0 --gst-version
> > GStreamer Core Library version 1.15.0.1
> > norman:~$ gst-discoverer-1.0 /data/file.ts
> > Analyzing file:///data/file.ts
> > Done discovering file:///data/file.ts
> >
> > Topology:
> >   container: MPEG-2 Transport Stream
> >     video: H.264 (High 4:2:2 Profile)
> >     audio: MPEG-2 AAC
> >     unknown: meta/x-klv

Why do you say it's undetected ? This lines indicated it is. It says
unknown, because it does not fit in any of the 3 categories discoverer
knows, which is video/audio/text.

> >
> > Properties:
> >   Duration: 0:00:19.095193925
> >   Seekable: yes
> >   Live: no
> >   Tags:
> >       language code: en
> >       audio codec: MPEG-2 AAC
> >       video codec: H.264
> >
> > John
> >
> > On 06/21/2018 01:41 PM, Arturo Flores wrote:
> > > I have a file that contains two streams: a video stream and a klv
> > > stream.  One problem I have encountered is it appears the KLV
> > > stream is not being detected when using gstreamer-1.0 .  For
> > > example, if I use gst-discoverer-0.10 on this file I get:
> > >
> > > ...
> > > Done discovering file://somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264
> > >     unknown: private/klv
> > > ...
> > >
> > >
> > > However, if I use the new gstreamer tool gst-discoverer-1.0, I
> > > get:
> > >
> > > Done discovering file:///somefilewithklv.mpg
> > >
> > > Topology:
> > >   container: MPEG-2 Transport Stream
> > >     video: H.264 (Baseline Profile)
> > >
> > > I am using gstreamer-1.0-1.14.1 if it makes a difference.  Should
> > > I be seing the unknown:private/klv stream when using the new gst-
> > > discoverer-1.0 ?
> > >
> > > Thanks
> > >
> > > Arturo
> > >
> > >
> > >
> > > _______________________________________________
> > > gstreamer-devel mailing list
> > > [hidden email]
> > > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> > 
> >
> > _______________________________________________
> > gstreamer-devel mailing list
> > [hidden email]
> > https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
> >
>
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel




_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel




_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel