How to install a plugin on GStreamer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

How to install a plugin on GStreamer

Damien Picard
Hi !

I'm trying to use GStreamer 1.10.4 on Debian Stretch (armhf/RaspberryPi). I install it using apt and it works fine.
Now, I try to add gst-omx 1.10.4 to use the raspberry GPU to do the h264 encoding. So I download the gst-omx gst-omx-1.10.4.tar.xz archive from gstreamer, and I configure/compile it using :


./autogen.sh --with-omx-header-path=/opt/vc/include/IL --with-omx-target=rpi
make
make install

it installs the libgstomx.o in /usr/local/lib/gstreamer-1.0

But, even if I install it, I can't see it with gst-inspect-1.0. How can I "declare" this lib to gstreamer ?

Thank you in advance.

--
Damien Picard
Expert GWT
Mob : 06 11 51 47 78

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to install a plugin on GStreamer

Damien Picard
Ok, sorry for the disturbance ; I got it :

export GST_PLUGIN_PATH=/home/pi/gst-omx/gst-omx-1.10.4/
export LD_LIBRAY_PATH=/usr/local/lib/gstreamer-1.0/

And it works :

root@rpi3-stretch:/home/pi/gst-omx/gst-omx-1.10.4# gst-inspect-1.0 | grep omx
omx:  omxmpeg2videodec: OpenMAX MPEG2 Video Decoder
omx:  omxmpeg4videodec: OpenMAX MPEG4 Video Decoder
omx:  omxh263dec: OpenMAX H.263 Video Decoder
omx:  omxh264dec: OpenMAX H.264 Video Decoder
omx:  omxtheoradec: OpenMAX Theora Video Decoder
omx:  omxvp8dec: OpenMAX VP8 Video Decoder
omx:  omxmjpegdec: OpenMAX MJPEG Video Decoder
omx:  omxvc1dec: OpenMAX WMV Video Decoder
omx:  omxh264enc: OpenMAX H.264 Video Encoder
omx:  omxanalogaudiosink: OpenMAX Analog Audio Sink
omx:  omxhdmiaudiosink: OpenMAX HDMI Audio Sink
libav:  avenc_h264_omx: libav OpenMAX IL H.264 video encoder encoder

I suppose that if I want to use a gstomx.conf file, I have to put it on GST_PLUGIN_PATH. I will verify it by now.


2017-03-15 8:53 GMT+01:00 Damien Picard <[hidden email]>:
Hi !

I'm trying to use GStreamer 1.10.4 on Debian Stretch (armhf/RaspberryPi). I install it using apt and it works fine.
Now, I try to add gst-omx 1.10.4 to use the raspberry GPU to do the h264 encoding. So I download the gst-omx gst-omx-1.10.4.tar.xz archive from gstreamer, and I configure/compile it using :


./autogen.sh --with-omx-header-path=/opt/vc/include/IL --with-omx-target=rpi
make
make install

it installs the libgstomx.o in /usr/local/lib/gstreamer-1.0

But, even if I install it, I can't see it with gst-inspect-1.0. How can I "declare" this lib to gstreamer ?

Thank you in advance.

--
Damien Picard
Expert GWT
Mob : 06 11 51 47 78



--
Damien Picard
Expert GWT
Mob : 06 11 51 47 78

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Loading...