How to compile a base plugin

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

How to compile a base plugin

Guillaume Denis
Hello,

I am new to GStreamer (and C) and I try to compile one of the base
plugin to learn (by modifying). After having installed various
dependencies (including libgstreamer-plugins-base1.0-dev) I get:


$ gcc -c audioecho.c `pkg-config --cflags --libs gstreamer-1.0`
In file included from audioecho.c:60:
audioecho.h:71:1: warning: data definition has no type or storage class
  GST_ELEMENT_REGISTER_DECLARE(audioecho);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
audioecho.h:71:1: warning: type defaults to 'int' in declaration of
'GST_ELEMENT_REGISTER_DECLARE' [-Wimplicit-int]
audioecho.h:71:1: warning: parameter names (without types) in function
declaration
audioecho.c:88:40: error: expected ')' before string constant
  GST_ELEMENT_REGISTER_DEFINE (audioecho, "audioecho",
                                         ^~~~~~~~~~~~
                                         )

I guess GST_ELEMENT_REGISTER_DECLARE and GST_ELEMENT_REGISTER_DEFINE
macros are not defined, but I don't know how to solve this. Many thanks
for your help! Guillaume
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: How to compile a base plugin

Olivier Crête-3
Hi,

If you are compiling the git master version of a plugin, you need to compile it against the git master version of the GStreamer core. We don't support mixing versions of the various GStreamer repositories. This macro was recently added, you could revert the relevant commit for this specific plugin if you want to backport it.

Olivier

On Tue, 2021-03-30 at 17:38 +0200, Guillaume Denis wrote:
Hello,

I am new to GStreamer (and C) and I try to compile one of the base
plugin to learn (by modifying). After having installed various
dependencies (including libgstreamer-plugins-base1.0-dev) I get:


$ gcc -c audioecho.c `pkg-config --cflags --libs gstreamer-1.0`
In file included from audioecho.c:60:
audioecho.h:71:1: warning: data definition has no type or storage class
  GST_ELEMENT_REGISTER_DECLARE(audioecho);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
audioecho.h:71:1: warning: type defaults to 'int' in declaration of
'GST_ELEMENT_REGISTER_DECLARE' [-Wimplicit-int]
audioecho.h:71:1: warning: parameter names (without types) in function
declaration
audioecho.c:88:40: error: expected ')' before string constant
  GST_ELEMENT_REGISTER_DEFINE (audioecho, "audioecho",
                                         ^~~~~~~~~~~~
                                         )

I guess GST_ELEMENT_REGISTER_DECLARE and GST_ELEMENT_REGISTER_DEFINE
macros are not defined, but I don't know how to solve this. Many thanks
for your help! Guillaume
_______________________________________________
gstreamer-devel mailing list

-- 
Olivier Crête


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel