Gst-plugins-bad 1.3.1 fails to compile

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Gst-plugins-bad 1.3.1 fails to compile

Dave
In trying to get the decklinksink to work I attempted to compile the latest gst-plugins-bad from git.  Autogen completes OK, however make fails with many errors regarding unknown types such as GLuint and GLenum.  Can anyone tell me which library I am likely missing for these types to be defined?

Regards,

Dave.
Reply | Threaded
Open this post in threaded view
|

Re: Gst-plugins-bad 1.3.1 fails to compile

Dave
Cancel that! I find it requires gst-plugins-gl to be installed first. Decklinksink still doesn't work for video though.
Reply | Threaded
Open this post in threaded view
|

AW: Gst-plugins-bad 1.3.1 fails to compile

BGraaf
In reply to this post by Dave
Hi Dave,

I have the same issue from git with gst-plugin-bad.
Seems to be uncompleted (missing such types).
 
Bernhard

-----Ursprüngliche Nachricht-----
Von: gstreamer-devel [mailto:[hidden email]]
Im Auftrag von Dave
Gesendet: Dienstag, 13. Mai 2014 06:31
An: [hidden email]
Betreff: Gst-plugins-bad 1.3.1 fails to compile

In trying to get the decklinksink to work I attempted to compile the latest
gst-plugins-bad from git.  Autogen completes OK, however make fails with
many errors regarding unknown types such as GLuint and GLenum.  Can anyone
tell me which library I am likely missing for these types to be defined?

Regards,

Dave.



--
View this message in context:
http://gstreamer-devel.966125.n4.nabble.com/Gst-plugins-bad-1-3-1-fails-to-c
ompile-tp4666941.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.
_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: AW: Gst-plugins-bad 1.3.1 fails to compile

Dave
Hi Bernhard,

Did you try compiling and installing the gst-plugins-gl first?  This solved the problem for me on Ubuntu 13.10.

Regards,

Dave.
Reply | Threaded
Open this post in threaded view
|

Re: AW: Gst-plugins-bad 1.3.1 fails to compile

Alston
This post was updated on .
while installing gst-plugins-gl, error message says it has been merged into gst-plugins-bad. See here http://cgit.freedesktop.org/gstreamer/gst-plugins-gl/commit/?id=bedade404ec82432742a901c663f18dfaa24356f

plugin-bad requires plugin-gl which has whereas been merged into plugin-bad, sad. any idea?
Reply | Threaded
Open this post in threaded view
|

Re: AW: Gst-plugins-bad 1.3.1 fails to compile

Tim Müller
On Tue, 2014-09-09 at 08:05 -0700, Alston wrote:

> gst-plugins-gl says it has been merged into gst-plugins-bad, autogen fail.
>
> any idea?

Just to be sure: please do not try to compile any 1.3.x versions any
more at this point, they were unstable development releases. What used
to be 1.3.x is now the stable 1.4.x series, so please try to compile the
latest 1.4 release instead (1.4.1) if you're not doing that already.
There were a lot of fixes between 1.3.1 and 1.4.0. If you are trying
with 1.4.1 already, and it's still a problem, please report a bug in
bugzilla, thanks!

Cheers
 -Tim

--
Tim Müller, Centricular Ltd - http://www.centricular.com

_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel