Quantcast

Green lines when playing video using gstreamer pipeline

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Green lines when playing video using gstreamer pipeline

Mayank Agarwal
Hi,

I am playing the rtp packets using following gstreamer pipeline but i am getting green lines as displayed in the attached image.

gst-launch-1.0 -v udpsrc port=62716 caps="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)RAW, sampling=(string){YCbCr-4:2:2}, depth=(string)8, width=(string)1280, height=(string)800, colorimetry=(string)BT709-2, payload=(int)96, ssrc=(uint)341085478, clock-base=(uint)342261484, seqnum-base=(uint)33150" ! rtpvrawdepay ! glimagesink.

1.I want to find out the reason of getting this green lines whether it is becasue the above gstreamer pipeline is not correct or becasue of actual packet loss.
2.How can i make sure that there is nothing wrong with the gstreamer pipeline.

Please also find the green line tint image attached.

Regards
Mayank



_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

gree_lines_on_video-min.png (355K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Green lines when playing video using gstreamer pipeline

Ronit P Zagade
can you send actual  command so i can try on my system
Loading...