GES hangs on MPEG2 program stream files?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GES hangs on MPEG2 program stream files?

Chris Wine
Hi, I'm using GStreamer/GES 1.18 on Windows, and having an issue where my GESTimeline hangs indefinitely when one of my input clips is a MPEG Program Stream file. I can also reproduce the issue with ges-launch-1.0.exe:

ges-launch-1.0.exe +clip SampleMpegProgramStream.mpg


With gst-play-1.0.exe, it is able to play the file all the way through successfully. Does anyone have any insight they could share with me?

Thanks,
--Chris

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: GES hangs on MPEG2 program stream files?

Thibault Saunier-4
Hello,

There indeed is an issue using that file with GES I do not know what is going on and some debugging would be needed to determine it. Check some GST_DEBUG logs to figure it out?

- Thibault

On Fri, Jan 8, 2021 at 2:30 PM Chris Wine <[hidden email]> wrote:
Hi, I'm using GStreamer/GES 1.18 on Windows, and having an issue where my GESTimeline hangs indefinitely when one of my input clips is a MPEG Program Stream file. I can also reproduce the issue with ges-launch-1.0.exe:

ges-launch-1.0.exe +clip SampleMpegProgramStream.mpg


With gst-play-1.0.exe, it is able to play the file all the way through successfully. Does anyone have any insight they could share with me?

Thanks,
--Chris
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel