Failed to load dtls plugin

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to load dtls plugin

Mayank Aggarwal
Hi,

I am getting an error while installing 1.16.2 version of gstreamer on CentOS 7.

[root@localhost gstreamer-1.0]# gst-inspect-1.0 /usr/lib64/gstreamer-1.0/libgstdtls.so

(gst-inspect-1.0:458): GStreamer-WARNING **: 16:55:42.241: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstdtls.so': /usr/lib64/gstreamer-1.0/libgstdtls.so: undefined symbol: BIO_meth_set_read
Could not load plugin file: Opening module failed: /usr/lib64/gstreamer-1.0/libgstdtls.so: undefined symbol: BIO_meth_set_read


Can load the dtls plugin. Can anybody help ?

Thanks,
Mayank

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load dtls plugin

kuttypaiyan
Mayank,

Install openssl , this should solve your issue.





--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load dtls plugin

Mayank Aggarwal

Openssl 1.1.1c is already installed. Still facing this issue.

-Mayank 

On Thu, Feb 6, 2020 at 10:58 PM kuttypaiyan <[hidden email]> wrote:
Mayank,

Install openssl , this should solve your issue.





--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel