Quantcast

Failed installation VAAPI with VDPAU backend and gststreamer version 1.10.4

classic Classic list List threaded Threaded
2 messages Options
LC
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Failed installation VAAPI with VDPAU backend and gststreamer version 1.10.4

LC
Hello,

I have a problem installing gstreamer-vaapi plugins with gstreamer build from source.

I have GeForce GTX 1080 and nvidia driver 375.

I made a test to install gstreamer base, bad, etc., vaapi plugins from .deb  packages. On ubuntu 16.04 there is pakgs of gstreamer with version 1.8.3. It installs vaapi decoder/encoder plugins. I saw that for vaapi package there is packaged one .so file and everything seems to work.

Than i used gstreamer-1.10.4 from Freedesktop.org. to install gstreamer, plugins base, bad, etc., vaapi. Vaapi ./configure does not show any errors, make and make install with no errors, but gst-inspect-1.0 | grep vaapi returns nothing.

gst-inspect-1.0 vaapi shows me the plugin details with 0 features below.

What may be wrong with vaapi plugins with VDPAU backend. What can test or do ?
Is there anyone having similar problem.

Thanks in advance!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failed installation VAAPI with VDPAU backend and gststreamer version 1.10.4

Victor Jaquez
On 03/24/17 at 05:42am, LC wrote:

> Hello,
>
> I have a problem installing gstreamer-vaapi plugins with gstreamer build
> from source.
>
> I have GeForce GTX 1080 and nvidia driver 375.
>
> I made a test to install gstreamer base, bad, etc., vaapi plugins from .deb
> packages. On ubuntu 16.04 there is pakgs of gstreamer with version 1.8.3. It
> installs vaapi decoder/encoder plugins. I saw that for vaapi package there
> is packaged one .so file and everything seems to work.
>
> Than i used gstreamer-1.10.4 from Freedesktop.org. to install gstreamer,
> plugins base, bad, etc., vaapi. Vaapi ./configure does not show any errors,
> make and make install with no errors, but gst-inspect-1.0 | grep vaapi
> returns nothing.
>
> gst-inspect-1.0 vaapi shows me the plugin details with 0 features below.
>
> What may be wrong with vaapi plugins with VDPAU backend. What can test or do
> ?
> Is there anyone having similar problem.

The VDPAU driver for VAAPI[1] is unmaintained, and many use-cases fail. Thus
gstreamer-vaapi has a white-list of drivers[2] that can work with, and
va-vdpau-driver is not in that list. That's why `gst-inspect-1.0 vaapi` shows
zero elements.

If you still want to try it, export the variable GST_VAAPI_ALL_DRIVERS=1, but
you are on your own.

1. https://cgit.freedesktop.org/vaapi/vdpau-driver/
2. https://bugzilla.gnome.org/show_bug.cgi?id=764673

>
> Thanks in advance!
>
>
>
> --
> View this message in context: http://gstreamer-devel.966125.n4.nabble.com/Failed-installation-VAAPI-with-VDPAU-backend-and-gststreamer-version-1-10-4-tp4682397.html
> Sent from the GStreamer-devel mailing list archive at Nabble.com.
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Loading...