Error restarting pipeline - decodebin bug?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Error restarting pipeline - decodebin bug?

Zeno Endemann
Hi,

With the attached minimal example I get an Internal data stream error
the second time the pipeline gets started (state gets set to
GST_STATE_PLAYING).

When I remove the decodebin it works as expected (but in the pipeline
I'm actually using I have a filesrc instead of a videotestsrc, so I need
it).

I am not doing anything wrong, am I? Should I report a bug? Any
work-around for the time being?


Thanks,

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

main.cpp (903 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error restarting pipeline - decodebin bug?

killerrats
This post was updated on .

Will work:

gst_element_set_state(pipeline, GST_STATE_PLAYING);
gst_element_set_state(pipeline, GST_STATE_PAUSED);
gst_element_set_state(pipeline, GST_STATE_PLAYING);

or

gst_element_set_state(pipeline, GST_STATE_PLAYING);
sleep(2);
gst_element_set_state(pipeline, GST_STATE_NULL);
pipeline = gst_parse_launch(pipelineDesc, NULL);
sleep(1);
gst_element_set_state(pipeline, GST_STATE_PLAYING);
sleep(2);
gst_element_set_state(pipeline, GST_STATE_NULL);

Will not work:

gst_element_set_state(pipeline, GST_STATE_PLAYING);
gst_element_set_state(pipeline, GST_STATE_PAUSED);
gst_element_set_state(pipeline, GST_STATE_NULL);
gst_element_set_state(pipeline, GST_STATE_PLAYING);



-----
------------------------------
Gstreamer 1.14.3
------------------------------
Windows
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
gstreamer-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
------------------------------
Gstreamer 1.14.3
------------------------------
Windows
Reply | Threaded
Open this post in threaded view
|

Re: Error restarting pipeline - decodebin bug?

Zeno Endemann
Ok well, I reported the issue now:

https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/issues/574

killerrats wrote on 23.03.19 01:07:

> Will work:
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
> gst_element_set_state(pipeline, GST_STATE_PAUSED);
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
> or
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
> sleep(2);
> gst_element_set_state(pipeline, GST_STATE_NULL);
> pipeline = gst_parse_launch(pipelineDesc, NULL);
> sleep(1);
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
> sleep(2);
> gst_element_set_state(pipeline, GST_STATE_NULL);
>
> Will not work:
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
> gst_element_set_state(pipeline, GST_STATE_PAUSED);
> gst_element_set_state(pipeline, GST_STATE_NULL);
> gst_element_set_state(pipeline, GST_STATE_PLAYING);
>
>
>
> -----
> ------------------------------
> Gstreamer 1.14.3
> ------------------------------
> Windows
> --
> Sent from: http://gstreamer-devel.966125.n4.nabble.com/
> _______________________________________________
> gstreamer-devel mailing list
> [hidden email]
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
>

_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel