Error in rtsp server installation

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Error in rtsp server installation

stproj
This post was updated on .
Greetings,

I am trying to install gstreamer rtsp server in order to build an application. What is wrong is that when i do ./configure on the folder i get this error:

checking for GST_BASE... yes
checking for GST_PLUGINS_BASE... no
configure: No package 'gstreamer-plugins-base-1.0' found
configure: error: no gstreamer-plugins-base-1.0 >= 1.6.0 (GStreamer Base Plugins) found


I tried  with different versions from lower branches but i get the same error. Moreover, i can compile and run test codes from http://cgit.freedesktop.org/gstreamer/gst-plugins-base/tree/?h=1.6 without a problem and gst-inspect --version gives:

gst-inspect-1.0 version 1.6.0
GStreamer 1.6.0


My gstreamer installation is in /usr/include , installed from official package.

I don't understand what seems to be the problem, so any help or direction would be very helpful.

Best regards,
S.

 
Reply | Threaded
Open this post in threaded view
|

Re: Error in rtsp server installation

Sebastian Dröge-3
On Di, 2015-12-01 at 15:35 -0800, stproj wrote:

> Greetings,
>
> I am trying to install gstreamer rtsp server in order to build an
> application. What is wrong is that when i do *./configure* on the
> folder i
> get this error:
>
> *checking for GST_BASE... yes
> checking for GST_PLUGINS_BASE... no
> configure: No package 'gstreamer-plugins-base-1.0' found
> configure: error: no gstreamer-plugins-base-1.0 >= 1.6.0 (GStreamer
> Base
> Plugins) found*
>
> I tried except with different version from lower branches but i get
> the same error. Moreover, i can compile and run test codes from
> http://cgit.freedesktop.org/gstreamer/gst-plugins-base/tree/?h=1.6
> <http://cgit.freedesktop.org/gstreamer/gst-plugins-
> base/tree/?h=1.6>  ; without a problem
What's the output of
  gst-inspect-1.0 videoscale | grep Version
and
  pkg-config --libs --cflags gstreamer-plugins-base-1.0
and
  pkg-config --modversion gstreamer-plugins-base-1.0
?

--
Sebastian Dröge, Centricular Ltd · http://www.centricular.com


_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

signature.asc (968 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error in rtsp server installation

stproj
Hello,

The output of   gst-inspect-1.0 videoscale | grep Version is Version                  1.6.0

The output both of   pkg-config --libs --cflags gstreamer-plugins-base-1.0   and   pkg-config --modversion gstreamer-plugins-base-1.0 

Package gstreamer-plugins-base-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-plugins-base-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-plugins-base-1.0' found


This makes me wondering if i am trying to build onto a wrong version of gstreamer. I also cannot find the file gstreamer-plugins-base-1.0.pc in pkg-config folders and usr/include

I also did a pkg-config --list-all | grep gst  to search for all the available gstreamer packages and the output is:
gstreamer-1.0                  GStreamer - Streaming media framework
gstreamer-net-1.0              GStreamer networking library - Network-enabled GStreamer plug-ins and clocking
gstreamer-base-1.0             GStreamer base classes - Base classes for GStreamer elements
gstreamer-check-1.0            GStreamer check unit testing - Unit testing helper library for GStreamer modules
gstreamer-controller-1.0       GStreamer controller - Dynamic parameter control for GStreamer elements


I am a bit confused.


Best Regards,
S.
Reply | Threaded
Open this post in threaded view
|

Re: Error in rtsp server installation

Sebastian Dröge-3
On Mi, 2015-12-02 at 04:07 -0800, stproj wrote:

> Hello,
>
> The output of   gst-inspect-1.0 videoscale | grep Version is
> *Version                 
> 1.6.0*
>
> The output both of   *pkg-config --libs --cflags gstreamer-plugins-
> base-1.0
> *  and  * pkg-config --modversion gstreamer-plugins-base-1.0*
>
> *Package gstreamer-plugins-base-1.0 was not found in the pkg-config
> search path.
> Perhaps you should add the directory containing
> `gstreamer-plugins-base-1.0.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'gstreamer-plugins-base-1.0' found*
This means that you have gst-plugins-base, but not the development
files (headers, etc) installed. You need to install those first.

--
Sebastian Dröge, Centricular Ltd · http://www.centricular.com


_______________________________________________
gstreamer-devel mailing list
[hidden email]
http://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

signature.asc (968 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Error in rtsp server installation

stproj
In reply to this post by Sebastian Dröge-3
Hello again,

Sebastian you were correct. I was missing  sudo apt-get install libgstreamer-plugins-base1.0-dev from my installation.

Best regards,
S.