Cannot play vp8 video using chromiumgstreamer backend

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cannot play vp8 video using chromiumgstreamer backend

getsoubl
Hello
We  have build the latest chromium + chromiumGstreamerBackend that is provided by Samsung in a Beebox intel platfrom that supports the latest intel drivers(i965)
We have check that the driver opens succesfully (run vainfo).

We have enable all the hardware accelatros settings(check gpu settings in chrome) . But video cannot be played . Specfically it seems that the video is loading without any progress. If we move the cursor we can see a snapshot of the frames but in the video frame a blank screen is appeared.
We run chromium using --no-sandbox.
If we run gstreamer standalone uisng vaapi all are fine.
Could you please help?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot play vp8 video using chromiumgstreamer backend

Hyunjun Ko
getsoubl wrote
Hello
We  have build the latest chromium + chromiumGstreamerBackend that is provided by Samsung in a Beebox intel platfrom that supports the latest intel drivers(i965)
We have check that the driver opens succesfully (run vainfo).

We have enable all the hardware accelatros settings(check gpu settings in chrome) . But video cannot be played . Specfically it seems that the video is loading without any progress. If we move the cursor we can see a snapshot of the frames but in the video frame a blank screen is appeared.
We run chromium using --no-sandbox.
If we run gstreamer standalone uisng vaapi all are fine.
Could you please help?
I guess that there is a problem from your sink element. (probably you're running it on wayland, right?)
Which sink element are you using? If it's implemented inside your specific chromium, the problem might be caused by it.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot play vp8 video using chromiumgstreamer backend

getsoubl
This post was updated on .
Hello,
We have built the libva using wayland. But because I am newbie in chromium develompent and integratin, I would like to ask how to check the current sink and how to change this sink.
Morever in media_player_gstreamer.cc , the glimagesink is set
GstElement* glimagesink = gst_element_factory_make("glimagesink", NULL);

Is this different form the wayland sink?


Thank you
Loading...