Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

new baby
Hi experts,

I am first time compiling gstreamer from source code and I am facing
difficulty in building gst-libav-1.0 in windows.

I followed link given in the gstreamer website. only creation of
.cerbero.cbc is avoided (as it gives lots more problems ,but default will
work it say in site)
https://gstreamer.freedesktop.org/documentation/installing/building-from-source-using-cerbero.html

 ISSUES

1) After running build command I am getting error of "*/w32pthreads.h:137:1:
error: unknown type name 'INIT_ONCE'"*  
For more detailed error see error.txt file
C:\\Users\\Admin\\AppData\\Local\\Programs\\Python\\Python36\\Python.exe
./cerbero-uninstalled buildone gst-libav-1.0


2) when I set the enable nvenc , cuda ...etc its showing :
configure: WAARNING: unrecognized options: --enable-hwaccels
--enable-devices --enable-nvenc --enable-omx   --enable-omx-rpi
--enable-cuda --enable-cuvid   --enable-libnpp  --enable-ffmpeg

I have added above option in file "gst-libav-1.0.recipe" at below mentioned
place

class Recipe(custom.GStreamer):
    name = 'gst-libav-1.0'
    # TODO - check license - plugin is certainly LGPLv2+, but need to check
    #        the linked libs
    licenses = [License.LGPLv2Plus]
    config_sh = 'sh ./autogen.sh --noconfigure && ./configure'
    configure_options = "--enable-lgpl --disable-examples --enable-static "
 
How can I enable this option in the build of libav ?

Note:
I have added logs generated while building "Python.exe ./cerbero-uninstalled
buildone gst-libav-1.0 / Python.exe ./cerbero-uninstalled  build
gst-libav-1.0 "

a) gst-libav-1.0-compile.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
b) gst-libav-1.0-configure.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
c) gst-libav-1.0-fetch.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
d) error.txt
error.txt
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/error.txt>  


Kindly help me in the above issues.
Thanks in advance .





gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log>  
error.txt
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/error.txt>  



-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
adi
Reply | Threaded
Open this post in threaded view
|

Re: Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

Black_13
its impossible to build 

On Thu, Jun 7, 2018 at 9:05 AM, new baby <[hidden email]> wrote:
Hi experts,

I am first time compiling gstreamer from source code and I am facing
difficulty in building gst-libav-1.0 in windows.

I followed link given in the gstreamer website. only creation of
.cerbero.cbc is avoided (as it gives lots more problems ,but default will
work it say in site)
https://gstreamer.freedesktop.org/documentation/installing/building-from-source-using-cerbero.html

 ISSUES

1) After running build command I am getting error of "*/w32pthreads.h:137:1:
error: unknown type name 'INIT_ONCE'"* 
For more detailed error see error.txt file
C:\\Users\\Admin\\AppData\\Local\\Programs\\Python\\Python36\\Python.exe
./cerbero-uninstalled buildone gst-libav-1.0


2) when I set the enable nvenc , cuda ...etc its showing :
configure: WAARNING: unrecognized options: --enable-hwaccels
--enable-devices --enable-nvenc --enable-omx   --enable-omx-rpi
--enable-cuda --enable-cuvid   --enable-libnpp  --enable-ffmpeg

I have added above option in file "gst-libav-1.0.recipe" at below mentioned
place

class Recipe(custom.GStreamer):
    name = 'gst-libav-1.0'
    # TODO - check license - plugin is certainly LGPLv2+, but need to check
    #        the linked libs
    licenses = [License.LGPLv2Plus]
    config_sh = 'sh ./autogen.sh --noconfigure && ./configure'
    configure_options = "--enable-lgpl --disable-examples --enable-static "

How can I enable this option in the build of libav ?

Note:
I have added logs generated while building "Python.exe ./cerbero-uninstalled
buildone gst-libav-1.0 / Python.exe ./cerbero-uninstalled  build
gst-libav-1.0 "

a) gst-libav-1.0-compile.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
b) gst-libav-1.0-configure.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
c) gst-libav-1.0-fetch.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
d) error.txt
error.txt
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/error.txt


Kindly help me in the above issues.
Thanks in advance .





gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
gst-libav-1.log
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/gst-libav-1.log
error.txt
<http://gstreamer-devel.966125.n4.nabble.com/file/t378175/error.txt



-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

new baby
I have seen few posts, using nvenc on windows with gstreamer . which
indicates that src building of gstreamer code along with gst-libav-1.0
package.


 



-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
adi
Reply | Threaded
Open this post in threaded view
|

Re: Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

new baby
I was able to figure out the above issues and fix ..


 changes
  1) thread.h (144)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav\libavutil)
  2) configure (6483)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav)
  3) w32pthreads.h (138)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav\compat)



-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
adi
Reply | Threaded
Open this post in threaded view
|

Re: Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

Black_13
were you able to build all the way through?
James

On Tue, Jun 12, 2018 at 2:45 AM, new baby <[hidden email]> wrote:
I was able to figure out the above issues and fix ..


 changes
  1) thread.h (144)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav\libavutil)
  2) configure (6483)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav)
  3) w32pthreads.h (138)
(C:\MinGW\msys\1.0\home\Admin\cerbero\build\sources\windows_x86_64\gst-libav-1.0-1.15.0.1\gst-libs\ext\libav\compat)



-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel


_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
Reply | Threaded
Open this post in threaded view
|

Re: Building gstreamer from source in windows using cerbero .... issues with building gst-libav-1.0

new baby
Yeah , currently I am able to generate two executables
(gstreamer-1.0-x86_64-1.15.0.1.exe &
gstreamer-1.0-devel-x86_64-1.15.0.1.exe).

But when I build gst-plugins-bad-1.0 with nvenc , nvdec and cuda .

 I was facing difficulty in assigning/setting  paths of cuda toolkit9.2 and
nvidia video sdk 8.2 with gst-plugins-bad-1.0 package . so I copied all
relevant .h & .lib in  below paths .

C:\MinGW\msys\1.0\home\aasim\cerbero\build\dist\windows_x86_64\include
C:\MinGW\msys\1.0\home\aasim\cerbero\build\dist\windows_x86_64\lib

configure.log

configure: *** checking feature: NVIDIA CUDA API ***
checking dynlink_cuda.h usability... yes
checking dynlink_cuda.h presence... yes
checking for dynlink_cuda.h... yes
checking cuda.h usability... yes
checking cuda.h presence... yes
checking for cuda.h... yes
checking cuda_runtime_api.h usability... yes
checking cuda_runtime_api.h presence... yes
checking for cuda_runtime_api.h... yes
checking for cudaGetErrorString in -lcudart... yes
checking for cuInit in -lcuda... yes

configure: *** checking feature: nvdec ***
configure: *** for plug-ins: nvdec ***
checking nvcuvid.h usability... yes
checking nvcuvid.h presence... yes
checking for nvcuvid.h... yes
checking dynlink_nvcuvid.h usability... yes
checking dynlink_nvcuvid.h presence... yes
checking for dynlink_nvcuvid.h... yes
checking for cuvidCtxLock in -lnvcuvid... yes
configure: *** These plugins will be built: nvdec

configure: *** checking feature: NVIDIA Encode API ***
configure: *** for plug-ins: nvenc ***
checking nvEncodeAPI.h usability... yes
checking nvEncodeAPI.h presence... yes
checking for nvEncodeAPI.h... yes
checking for NvEncodeAPICreateInstance in -lnvidia-encode... no
configure: WARNING: Could not find library nvidia-encode
configure: *** These plugins will not be built: nvenc
 

ISSUE:
*Now I am able to detect the cuda & nvdec but not nvenc .*

nvenc is looking for nvidia-encode.dll but in  nvidia video sdk 8.2 , the
nvidia-encode.dll is missing but its present in Linux folder as
nvidia-encode.so .








-----
adi
--
Sent from: http://gstreamer-devel.966125.n4.nabble.com/
_______________________________________________
gstreamer-devel mailing list
[hidden email]
https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel
adi